Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help! Shopping card does not refresh


rudolfl

Recommended Posts

Hi, all

 

I admit, I am new to osCommerce. Trying to set up a shop and get an interesting problem (use osComemrce 2.2 MS2).

 

Browse to shop, add product to a shopping cart. At this time product appears in the shopping cart box.

Click on checkout and it takes you to login page. At this point, shopping cart box shows as empty. Clicking on arrow next to box nam restores it.

Log in and shopping cart is empty (both on page and in box). Clicking on arrow again shows products in the cart and in the box.

 

Any ideas?

 

Here is site: http://www.hatsfromoz.com.au

 

Thanks,

Rudolf

Link to comment
Share on other sites

Ensure that the information for your SSL side in your includes/configure.php is correct since you are using a shared SSL. It sounds like the session settings are incorrect.

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

Ensure that the information for your SSL side in your includes/configure.php is correct since you are using a shared SSL. It sounds like the session settings are incorrect.

 

Yes, you are right. Problems is not retaining cookies when jumping from HTTP to HTTPS. I think it is solved now by changing /includes/configure.php

 

define('HTTP_COOKIE_DOMAIN', 'SHOP ADDRESS');

define('HTTPS_COOKIE_DOMAIN', 'PROVIDER ADDRESS');

 

PROVIDER ADDRESS was taken from browser address line when jumping to https. I guess, if i have own certificate it will work ok without any changes.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...