Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

adding mods now or later? Also DB or File setup


autocards

Recommended Posts

Hi All!

VERY Newbie here. I just purchased a template and the guy did a new install for me for a new start up store. This is all new to me so a bit overwhelmed right now. (but I will conquer this!)

I'm assuming I have the latest version installed. I saw in a post how to tell what ver. you have so I checked that. this is one of the first lines... $Id: application_top.php,v 1.280 2003/07/12 09:38:07 hpdl Exp $

There is a line way down that says... define the project version define('PROJECT_VERSION', 'osCommerce 2.2-MS2'); So I'm assuming it is the most current? Any way of telling if there are any patches that should be installed?

How do I tell if any mods were installed?

There are some mods I noticed posted that look like we could use. Any suggestions if it would be best to install now (while we are fresh and have no products entered) Or if it is ok to install later as we go?

I also saw that it is a good idea not to have your session storage in files vs. database if you are on a shared server (which we are). How can I tell how he set it up?

Thanks for you input.

Link to comment
Share on other sites

I'm assuming I have the latest version installed. I saw in a post how to tell what ver. you have so I checked that. this is one of the first lines... $Id: application_top.php,v 1.280 2003/07/12 09:38:07 hpdl Exp $

There is a line way down that says... define the project version define('PROJECT_VERSION', 'osCommerce 2.2-MS2'); So I'm assuming it is the most current? Any way of telling if there are any patches that should be installed?

Never assume - an update was issued November 2005 to patch security holes (see the download section for details) and I'm not convinced that your template would include these. If in doubt, do a file comparison with a patched page & check that your code is indeed up-to-date.

Details of patches are here:

http://www.oscommerce.com/ext/update-20051113.html

Just download a page via FTP and see if the updates are in there - that'll tell you definitely whether your store is up-to-date or not.

 

How do I tell if any mods were installed?

If your template is from Template Monster then chances are it has no added functionality, but its code has been severly mangled to "make it look pretty". If it's from somebody else, then you need to ask them or do a comparison with a standard osCom download. Usually, if functionality has been added, then the admin area has extra fields or boxes from the standard osCom shop.

 

There are some mods I noticed posted that look like we could use. Any suggestions if it would be best to install now (while we are fresh and have no products entered) Or if it is ok to install later as we go?

Both can work, really depends on what you want to do. Rule of thumb: very big mods (multi-store) etc. must be done on a clean, standard osCom shop. Smaller mods can be done at any time. You might need to work manually with a template as it might not have the standard osCom code.

I also saw that it is a good idea not to have your session storage in files vs. database if you are on a shared server (which we are). How can I tell how he set it up?

In your two configure.php files:

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

If it's stored in database, it'll say "mysql". You need to access these files via FTP. Storing sessions in the database is definitely the way to go - much safer.

 

all the best, Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...