Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Parse Error; need fixing!


jpweber

Recommended Posts

I have this in my new box page, which is login.php (it's going in the OSC right column), located in catalog/includes/boxes:

 

<------------------- Code ------------------>

new infoBoxHeading($info_box_contents, false, false);

 

$info_box_contents = array();

$info_box_contents[] = array('text' => '<a href="http://mysite.com/catalog/login.php?osCsid=d588ac8f1fffe6b3c490188a40eaafce?osCAdminID=f3cdab335d59c0920155ebdb035fe1c4">'Login'</a><br>' .

'<a href="http://mysite.com/catalog/create_account.php?osCsid=d588ac8f1fffe6b3c490188a40eaafce?osCAdminID=f3cdab335d59c0920155ebdb035fe1c4">'Create an Account'</a>') ;

 

new infoBox($info_box_contents);

<------------------- Code ------------------>

 

I keep getting this error message:

Parse error: syntax error, unexpected T_STRING, expecting ')' in /catalog/includes/boxes/login.php on line 23

 

I'm not sure if I'm allowed to put hard http:// types of links in there like I did, or if my syntax is off just a tad, or what. If anyone knowledgable enough in this can please take the time to help me, it would be greatly appreciated!

 

J

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

Nevermind all. I fixed it just by googling, and messing around with various syntaxes, and finally finding the right one. I'd delete this if I knew how. If anyone's interested, the answer is here:

 

http://www.oscommerce.com/forums/lofiversion/i...hp/t130120.html

 

My proper coding is:

$info_box_contents[] = array('text' => '<a href="http://mysite.com/catalog/login.php?osCsid=d588ac8f1fffe6b3c490188a40eaafce?osCAdminID=f3cdab335d59c0920155ebdb035fe1c4">' . Login . '</a><br>'.

'<a href="http://mysite.com/catalog/create_account.php?osCsid=d588ac8f1fffe6b3c490188a40eaafce?osCAdminID=f3cdab335d59c0920155ebdb035fe1c4">Create an Account</a>');

 

Because the first hyperlink is defined as a language file, while the 2nd isn't. Shew!

 

J

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...