Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Moved Catalog to Root


Mark Miller

Recommended Posts

I moved the contents of the catalog folder to the root of my site. I then edited the Configure.php to make things work. All seems well except for when I am in Admin and on a Add Product page the icons and images do not show up. You get the generic red X. Same with when I add a product the image will not show up for the product. When I am in the store all is fine so I'm assuming that it is the configure.php in Admin but I can't see the problem. Here is the contents of admin/includes/config.php...

 

define('HTTP_SERVER', 'http://www.isthmusmodels.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.isthmusmodels.com');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/home/httpd/vhosts/isthmusmodels.com/httpdocs/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/httpd/vhosts/isthmusmodels.com/httpdocs/Admin'); // absolute pate required

define('DIR_WS_CATALOG', '//'); // absolute path required

define('DIR_FS_CATALOG', '/home/httpd/vhosts/isthmusmodels.com/httpdocs/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

Any hints?

 

Mark Miller

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...