Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

What is the base version of MySQL this will run on??


vaughnn

Recommended Posts

I have done some huting around in the documentation and forums, and can find the base level of php that osCommerce will run on, but I desperately need to know the base level of MYSQL the software will run on.

 

This is crucial, as I have a site which is behaving funny, and believe it is due to the version of MySQL.

 

Thanks a lot in advance.

 

Vaughnn

Link to comment
Share on other sites

Hello,

 

I had problems with connecting PHP4 with MySQL5, the password hashing wasn't compatible. The resolution was to install PHP5 to work with the MySQL5, since they use the same hashing algoritam for passwords.

 

Kata

Link to comment
Share on other sites

There are some notes in the osc readme file you may want to look:

 

With no restrictions or special requirements, osCommerce is able to run on any

PHP3 or PHP4 enabled web server, on any environment that PHP and MySQL

supports, which includes Linux, Solaris, BSD, and Microsoft Windows

environments.

 

available from the downloads.

 

I had problems with connecting PHP4 with MySQL5, the password hashing wasn't compatible. The resolution was to install PHP5 to work with the MySQL5, since they use the same hashing algoritam for passwords.

I've ported databases between PHP4-5,MySQL4-5 and did not see problems with the md5 hash.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...