Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

adding ssl to an existing site


esanzalone

Recommended Posts

I put up a site about a month ago & am now trying to add the ssl to it but have been getting a weird problem. when checking out the page comes up in https: format but no lock shows up in the browser. I setup another website with ssl at install & it works. if someone could tell me what i am doing wrong. here is the configure.php file.

 

define('HTTP_SERVER', 'http://www.oldworldcandles.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://weballiance.weballiance.biz/oldworldcandles.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.oldworldcandles.com');

define('HTTPS_COOKIE_DOMAIN', 'www.oldworldcandles.com');

define('HTTP_COOKIE_PATH', '/catalog');

define('HTTPS_COOKIE_PATH', '/catalog');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

Link to comment
Share on other sites

HTTPS_COOKIE_DOMAIN should be weballiance.weballiance.biz/oldworldcandles.com

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

ok i changed the cookie part but it still not working. as shown

define('HTTPS_COOKIE_DOMAIN', 'https://weballiance.weballiance.biz/oldworldcandles.com');

 

now this is the only file that i change ( sorry also the one in the admin section), is there anything else that needs to be changed.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...