Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Access denied for user: '[email protected]' (Using password: YES)


dkweb

Recommended Posts

Hi

 

First excuse my language, but i never learn it in school, but i am shure about you will understand me anyway.

 

When i try to install osCommerce i get a error when i submit the database informations and all this informations is 100% correct but i allways get this error:

Access denied for user: '[email protected]' (Using password: YES)

I have contacted the provider and they say:

 

ws7.surf-town.net is the webserver

the phpMyAdmin is: wsi1.surf-town.net but i am not able to change this.

 

What can i do??

 

Thank you

 

Best Regards

Mogens, DK

Link to comment
Share on other sites

ws7.surf-town.net is the webserver

 

That's not the same as saying it's the database server address. I'd recommend you try localhost for db_server, and if that doesn't work then try 127.0.0.1 (the ip address of localhost).

 

Vger

Link to comment
Share on other sites

Hi

The problem is solved - in the field wirh the nam of the database i just write the name - not db_ before but now i have another problem who is coming when i click on the administration tools then i get this :

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid/gid is 119993/119993 is not allowed to access owned by uid/gid 0/0 in /hsphere/local/home/helpdesk/postcard4sale.com/admin/includes/functions/sessions.php on line 110

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/helpdesk/postcard4sale.com/admin/includes/functions/sessions.php:110) in /hsphere/local/home/helpdesk/postcard4sale.com/admin/includes/functions/sessions.php on line 67

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/helpdesk/postcard4sale.com/admin/includes/functions/sessions.php:110) in /hsphere/local/home/helpdesk/postcard4sale.com/admin/includes/functions/sessions.php on line 67

 

 

What do i have to do/write/change here?

 

Thanks

Mogens,DK

Link to comment
Share on other sites

And when i go to: www.postcard4sale.com i get this:

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid/gid is 119993/119993 is not allowed to access owned by uid/gid 0/0 in /hsphere/local/home/helpdesk/postcard4sale.com/includes/functions/sessions.php on line 148

 

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/helpdesk/postcard4sale.com/includes/functions/sessions.php:148) in /hsphere/local/home/helpdesk/postcard4sale.com/includes/functions/sessions.php on line 97

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/helpdesk/postcard4sale.com/includes/functions/sessions.php:148) in /hsphere/local/home/helpdesk/postcard4sale.com/includes/functions/sessions.php on line 97

 

Thanks

 

Mogens,DK

Link to comment
Share on other sites

  • 1 month later...

I am getting the same error...

 

Access denied for user: 'simplymagickal.com@localhost' (Using password: YES)

 

YES, I've made sure that all of the information is correct. It has been double checked by the system administrator, and he says it's correct. We have both checked the permissions on the config files as well as necessary folders. I have just about as much access as an admin on the server, so it's not like I don't have permission to do something. Yes, a database has been created (actually, we made a second one just to see if the first one was the issue...same error message).

 

I have used this in the past and have NEVER had this many issues. The only thing I have done different is I had to install the Vger patch due to the globals issue.

 

Any thoughts? I'd hate to have to switch to another shopping cart system after all these years.

osCommerce 2.2 Milestone 2 Update 051113

Environment: Apache 2.0.54 (Debian GNU/Linux), MySQL 4.0.24, PHP 5.0.5-1

Link to comment
Share on other sites

I am getting the same error...

 

Access denied for user: 'simplymagickal.com@localhost' (Using password: YES)

 

 

This error comes from the database. It means the code is attempting to make a connection, but the database is rejecting on the basis of username, host, or password. Change your password to be sure you have the right thing. Is your database user set up as simplymagickal.com@localhost in the database or as something else, like simplymagickal.com@%?

Contributions

 

Discount Coupon Codes

Donations

Link to comment
Share on other sites

This error comes from the database. It means the code is attempting to make a connection, but the database is rejecting on the basis of username, host, or password. Change your password to be sure you have the right thing. Is your database user set up as simplymagickal.com@localhost in the database or as something else, like simplymagickal.com@%?

 

I have already verified password, changed password, etc. The password IS correct. As to "localhost," I've tried localhost, the IP, and simplymagickal.com and none worked. Like I said, all information has been verified by both myself AND the person who runs the server. The information is all correct, double checked, and tried on a completely different domain as well with a db on that domain, etc. It gives the same error.

osCommerce 2.2 Milestone 2 Update 051113

Environment: Apache 2.0.54 (Debian GNU/Linux), MySQL 4.0.24, PHP 5.0.5-1

Link to comment
Share on other sites

I have already verified password, changed password, etc. The password IS correct. As to "localhost," I've tried localhost, the IP, and simplymagickal.com and none worked. Like I said, all information has been verified by both myself AND the person who runs the server. The information is all correct, double checked, and tried on a completely different domain as well with a db on that domain, etc. It gives the same error.

 

 

Try a simple PHP script to connect to the database. OSC is not doing anything special here.

 

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
  die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

 

The way the admin has your username set up in MySQL can make a difference. Have you verified how your user name is set up?

Contributions

 

Discount Coupon Codes

Donations

Link to comment
Share on other sites

Try a simple PHP script to connect to the database. OSC is not doing anything special here.

 

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
  die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

 

The way the admin has your username set up in MySQL can make a difference. Have you verified how your user name is set up?

 

Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'simplymagickal.com@localhost' (Using password: YES) in /home/simplymagickal.com/public_html/www/ckdb.php on line 2
Could not connect: Access denied for user: 'simplymagickal.com@localhost' (Using password: YES)

 

I've asked him to delete everything related to this domain off the server and re-setup everything all over again. Both of us are completely baffled. I've never had issues in the past with osCommerce. I use it for several of my clients (all pre 2.2 though). I'll see if it still has issues after the wipe. This is so frustrating.

 

I do appreciate everyone taking the time to respond.

osCommerce 2.2 Milestone 2 Update 051113

Environment: Apache 2.0.54 (Debian GNU/Linux), MySQL 4.0.24, PHP 5.0.5-1

Link to comment
Share on other sites

Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'simplymagickal.com@localhost' (Using password: YES) in /home/simplymagickal.com/public_html/www/ckdb.php on line 2
Could not connect: Access denied for user: 'simplymagickal.com@localhost' (Using password: YES)

 

I've asked him to delete everything related to this domain off the server and re-setup everything all over again. Both of us are completely baffled. I've never had issues in the past with osCommerce. I use it for several of my clients (all pre 2.2 though). I'll see if it still has issues after the wipe. This is so frustrating.

 

I do appreciate everyone taking the time to respond.

 

If you got this error by running the script above, then the problem has absolutely nothing to do with OSCommerce. It's a database administration issue. Unless you have admin privileges on the database server, then there's not much you can do but wait for your host to fix it.

Contributions

 

Discount Coupon Codes

Donations

Link to comment
Share on other sites

Many servers require that you add the (short) domain prefix to the username and database name, eg.

 

user: simplym_simplymagickal (even though the user you created is "simplymagikal")

 

database: simplym_magikdatabase (even though the database you created is "magikdatabase")

 

This is so you dont get two databases/users the same on a shared server and makes it easy for an admin to recognise YOUR databases/users :)

 

You will need to LOOK for what the correct prefix is - if you have cPanel you will see it when you open the MySQL databases page.

 

"localhost is fine"... its just refusing the connection

 

Catblack

Link to comment
Share on other sites

If you got this error by running the script above, then the problem has absolutely nothing to do with OSCommerce. It's a database administration issue. Unless you have admin privileges on the database server, then there's not much you can do but wait for your host to fix it.

 

I have pretty much next to everything an admin does believe it or not. I've asked for my account to be deleted and re-setup just in case something went wonky when it was originally set up. Hopefully that will solve whatever issue is causing this.

osCommerce 2.2 Milestone 2 Update 051113

Environment: Apache 2.0.54 (Debian GNU/Linux), MySQL 4.0.24, PHP 5.0.5-1

Link to comment
Share on other sites

Hi.

 

I'm new to osCommerce and all but the login problems kinda reminded me of when I was setting up another GPL system that was using mySQL. The new versions of mySQL uses a new and different way of calculating the hash value for the passwords so if osCommerse uses the old type, the passwords won't add up even if typed identically. To change the password on the mySQL database to use old passwordhash you'd have to type something along the lines of:

"set password for <username>@<host> = old_password('<password>')". (without <>'s)

 

For the correct syntax, just google "SQL old_password".

 

-Larantz-

Link to comment
Share on other sites

Hi.

 

I'm new to osCommerce and all but the login problems kinda reminded me of when I was setting up another GPL system that was using mySQL. The new versions of mySQL uses a new and different way of calculating the hash value for the passwords so if osCommerse uses the old type, the passwords won't add up even if typed identically. To change the password on the mySQL database to use old passwordhash you'd have to type something along the lines of:

"set password for <username>@<host> = old_password('<password>')". (without <>'s)

 

For the correct syntax, just google "SQL old_password".

 

-Larantz-

 

This is a good catch - it can certainly happen. To clarify however, this will only happen if your host has installed a version of MySQL that is more recent than the PHP libraries are built for, and they have solved the "authentication method not supported by client" error by placing the "old_passwords" line in the my.cnf file and restarted the mysql server. It also requires that they have made this change AFTER they set up your username and password (so that your password is stored by mysql using the newer, longer hash function instead of the older, shorter one). The way to fix this is to recreate the password.

Contributions

 

Discount Coupon Codes

Donations

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...