Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Admin E-mails not working


param_nirvana

Recommended Posts

Hi all,

I have been trying to fix my e-mails which I managed to fix upto some extent but Admin e-mails are still not working.

 

After much of searching, googling and research I couldn't find any solution. During experimentation I found that e-mails work when sent from any other folders but not from admin folders and it's subfolders.

 

Above point was prooved when I used Email Testing scripts to run them from various folders. From all other folders both PHP and OSC e-mails are working but not from Admin folder. Following are e-mail test scripts which I tried

 

http://www.oscommerce.com/community/contributions,1595

And

<?php
define('TEST_EMAIL_ACCOUNT', '[email protected]');
echo TEST_EMAIL_ACCOUNT;
if(mail("[email protected]", "TEST EMAIL", "Test Email "))
{
echo"SUCCESS";
}else{
echo"FAILURE";
}
?>

Following are my environment

Windows 2003, IIS6, SMTP ports are opened by ISP (I confirmed with them), I used my ISP SMTP server as well as my domain SMTP server (both same result). No Firewall, Ports ar eopened in NAT, No blocking of ports in antivirus.

 

My settings in Admin->Store are

Configuration->E-mail Options:

E-Mail Transport Method = SMTP

E-Mail Linefeeds = CRLF

Verify E-Mail addresses through DNS = false

Send E-mails = true

 

Is there any problem with folder permissions?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...