Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

404 Error

midnight hacker

Recommended Posts

can someone help me i am new and was wondering if someone could help me out

my installation went fine but when i goto my catalog site i get 404 error.

the hosting company replied with this:


The most likely reason your cart is non functional is because you have nondefault directives in your .htaccess files. Since we have php as a cgi, and not as an apache module, you can't specify php settings in the .htaccess files. As php does not control apache's configureation, you can not have apache directives in your php.ini. If you have any further questions, pleaser reply to this message.


can someone tell me what i should do to rectify this problem? or point me to the right direction?


thank you


Midnight Hacker


p.s. this is the error:


Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@dynamictechnologies.ca and inform them of the time the error occurred, and anything you might have done that may have caused the error.


More information about this error may be available in the server error log.



Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.





Apache/1.3.34 Server at www.dynamictechnologies.ca Port 80

Link to comment
Share on other sites

Try renaming the .htaccess file in the catalog folder to txt.htaccess and see if that does it.




no go tried that this the error log:


[Thu Jun 15 20:47:49 2006] [error] [client] Premature end of script headers: /usr/home/dynamict/public_html/catalog/index.php


and here is .htaccess:


$Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $


# This is used with Apache WebServers


# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration


# Example:


# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>


# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)


# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers


<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0




# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter


# AcceptPathInfo On


# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)


<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1


Options All Indexes

IndexOptions FancyIndexing

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...