Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PayPal Shopping Cart IPN v1.3


Leak-Proof

Recommended Posts

I have PayPal Shopping Cart IPN v1.3 which has been testing OK. I have made several contribution installs and am now getting the following result in the Admin>PayPal IPN window

 

 

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.txn_id, p.parent_txn_id, p.paypal_id, p.txn_type, p.payment_type, p.payment_status, p.pending_reason, p.mc_currency, p.mc_fee, p.payer_status, p.mc_currency, p.date_added, p.mc_gross, p.payment_date from paypal as p order by p.paypal_id DESC limit -20, 20

 

[TEP STOP]

 

 

 

All the different selections give corresponding error messages i.e./

 

 

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.txn_id, p.parent_txn_id, p.paypal_id, p.txn_type, p.payment_type, p.payment_status, p.pending_reason, p.mc_currency, p.mc_fee, p.payer_status, p.mc_currency, p.date_added, p.mc_gross, p.payment_date from paypal as p where p.payment_status = 'Pending' order by p.paypal_id DESC limit -20, 20

 

[TEP STOP]

 

 

I think the offending contribution was one of these:

 

Shipping Status v3.2

 

Supertracker Contribution for osCommerce Version 3.20b

 

Blacklist v1.2

 

Order Editor2.5 (but this ones been in for a while)

 

If someone could direct me to the best place to start looking and what to look for, I can go live with the store.

 

 

 

I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Link to comment
Share on other sites

  • 2 months later...

Hi.

 

I copied this from the community member SPAX on another forum question.

 

Read this: http://www.oscommerce.com/ext/update-20051113.htmlPaying attention to "limit -20, 20" (1064 error) and "MySQL 5.0 Compatibility" (1054 error)

 

If you following these directions, you should be able to fix the problem.

 

Make sure to make a backup of your cart before attempting these fixes.

 

I hope this helps.

 

Have a great day.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...