Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

my gif buttons are not showing


moisea

Recommended Posts

hi everyone,

i have just uploaded the site i was working on my localhost to a new server. however, none of my gif buttons i designed and which was working perfectly on my local,are NOT showing at all.

has someone got an idea on how to fix this?

many thanks...

Link to comment
Share on other sites

Hi,

 

I'm getting this exact same problem with the quick find gif image. I think that it is to do with the image being in a subdirectory of the 'includes' directory (/includes/languages/english/images/buttons/button_quick_find.gif) - I cannot get any files at any level below that directory to display in the browser. I suspect that this is correct behaviour???

 

So why doesn't the function 'tep_image_submit' which is being called not display the image? Or perhaps why is that function being used?

 

Anyone any ideas?

 

Cheers,

 

Mark

 

hi everyone,

i have just uploaded the site i was working on my localhost to a new server. however, none of my gif buttons i designed and which was working perfectly on my local,are NOT showing at all.

has someone got an idea on how to fix this?

many thanks...

Link to comment
Share on other sites

Hi,

 

I'm getting this exact same problem with the quick find gif image. I think that it is to do with the image being in a subdirectory of the 'includes' directory (/includes/languages/english/images/buttons/button_quick_find.gif) - I cannot get any files at any level below that directory to display in the browser. I suspect that this is correct behaviour???

 

So why doesn't the function 'tep_image_submit' which is being called not display the image? Or perhaps why is that function being used?

 

Anyone any ideas?

 

Cheers,

 

Mark

 

hi mark, i do not get why it doesn't work it has been working fine on my localhost. please, let me know how you get on.

Link to comment
Share on other sites

Sorted. There is a .htaccess file in the root of the /includes/ directory that causes Apache to deny http access to the files in that directory and all subdirectories.

I've removed this file and now Apache will serve the image!

 

This is the content of the .htaccess file:

 

# $Id: .htaccess,v 1.4 2001/04/22 20:30:03 dwatkins Exp $

#

# This is used with Apache WebServers

# The following blocks direct HTTP requests in this directory recursively

#

# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration

#

# Example:

#

#<Directory "/usr/local/apache/htdocs">

# AllowOverride Limit

#

# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)

#

# This does not affect PHP include/require functions

#

# Example: http://server/catalog/includes/application_top.php will not work

 

<Files *.php>

Order Deny,Allow

Deny from all

</Files>

 

I guess that it is there as a security consideration, but as it blocks the serving of images from the language directories I don't know why it is there.

 

I suspect that Apache was setup differently between your two servers - hence the problem on one.

 

Cheers,

 

Mark

 

hi mark, i do not get why it doesn't work it has been working fine on my localhost. please, let me know how you get on.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...