Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

No Show!


Leak-Proof

Recommended Posts

In my store, I have a number of top level catagories, and some sub-catagories. The products all show fine in the index page and in the catagories box. My problem is that there are two sub-catagories that have too many products listed, so I made five sub-sub-catagories and placed the products in their proper sub-sub-catagories. They do show up in the catagories box, but do not show in the main window when I select the sub-catagories name. Those links work like normal. I would expect that the new sub-sub-catagories would be seen on the main page, but I get this instead,

 

 

 

There are no products to list in this category.

 

 

 

Did I change the code by mistake during one of my 30 or so contribution installs or is this the way it is suppose to work?

 

Another thing I have modified is that I included HTML code in the catagory and product names to better identify each product catagory to the viewer of the store. To accomodate the code, I increased the database size for product_name to (varchar 160) and catagory_name to (varchar 190).

 

 

 

The store is at https://leak-proof.com/catalog (not live yet)

 

 

 

Any idea on where to look for a fix so my products will show in their new sub-sub-catagories?

I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Link to comment
Share on other sites

In my store, I have a number of top level catagories, and some sub-catagories. The products all show fine in the index page and in the catagories box. My problem is that there are two sub-catagories that have too many products listed, so I made five sub-sub-catagories and placed the products in their proper sub-sub-catagories. They do show up in the catagories box, but do not show in the main window when I select the sub-catagories name. Those links work like normal. I would expect that the new sub-sub-catagories would be seen on the main page, but I get this instead,

 

 

 

 

 

 

 

Did I change the code by mistake during one of my 30 or so contribution installs or is this the way it is suppose to work?

 

Another thing I have modified is that I included HTML code in the catagory and product names to better identify each product catagory to the viewer of the store. To accomodate the code, I increased the database size for product_name to (varchar 160) and catagory_name to (varchar 190).

 

 

 

The store is at https://leak-proof.com/catalog (not live yet)

 

 

 

Any idea on where to look for a fix so my products will show in their new sub-sub-catagories?

 

 

 

Fixed.

 

I missed some code during the install of a mod.

I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...