Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals is disabled in your PHP configuration


shiftlocked

Recommended Posts

Hi there,

 

Wonder if someone can help. Im with Site5.com hosting and ive installed oscommerce via fantastico and its not working

 

http://www.thermaltech.co.uk/shop2/

http://www.thermaltech.co.uk/shop2/admin/

 

being up the following error

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

They say that I have to write my own Php.ini and put it into the directory of the shop, however since this was installed via fantasico I shouldnt have to do that. This i know becuase i had a shop that was running but since the server crashed somethings are acting odd, like easy populate for example.. That worked perfectly before it all went pear.

 

Ive seen a contribution on here to get around this error but I believe that it breaks easy poplulate so can anyone advise what to do.

 

TIA

Things still to do before going "live" in no real order...

Change "buy now buttons" css styles

Change "lets see what we have here" into something meaningfull

Main logo of the website

Sort out currency to make site UK only (at present)

Remove "xx requests since" stuff

Update mainpage :D

Move shopping cart status into header

Add in stock status to product listing page

Define styles for product listing standardisation

Change CSS background for Headings

Increase Category size headings

Used mods so far:- basic_design_pack1mk7 | Google XML sitemap w admin | Paypal IPN v 1.2 | Feedmachine | pricematch_1_3_1 | Dynamic Sitemap 1.6 | Whos online Enhancement | Easypopulate 2.72

 

Each one that I solve I;ll be putting a post on the forum in a "completed shop" thread that Im writing up

Link to comment
Share on other sites

Installing w/fantastico is easy, but it can't overcome your server's settings.

 

Your host is running w/register globals off. This change probably came after the "crash".

 

You can try putting an .htaccess file in your root with the following statement in it

 

php_flag register_globals on

 

If that doesn't work, then you'll likely have to use the register globals patch, which is in the contribution section I think.

 

Easy populate won't work w/register globals off either, the fix for that is in the easy populate thread. Just search that thread for "register globals".

 

 

Hi there,

 

Wonder if someone can help. Im with Site5.com hosting and ive installed oscommerce via fantastico and its not working

 

http://www.thermaltech.co.uk/shop2/

http://www.thermaltech.co.uk/shop2/admin/

 

being up the following error

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

They say that I have to write my own Php.ini and put it into the directory of the shop, however since this was installed via fantasico I shouldnt have to do that. This i know becuase i had a shop that was running but since the server crashed somethings are acting odd, like easy populate for example.. That worked perfectly before it all went pear.

 

Ive seen a contribution on here to get around this error but I believe that it breaks easy poplulate so can anyone advise what to do.

 

TIA

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...