Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How to set Cache?


JemCraft

Recommended Posts

In Admin -> config -> cache, I have:

 

Use Cache --- True

Cache Directory --- /cache

 

However, in Admin -> Tools -> Cache Control, i get 'Error: Cache directory does not exist. Please set this Configuration->Cache.' Appear at the top of the screen.

 

I have checked the file manager and I have a file named Cache with permissions set to 777, so why isn't this working?

 

Thanks

Jemma

Link to comment
Share on other sites

Instead of /cache you need to set it too the full path on your server.

 

If you are not sure what that is try going to file manager. At the top, just below the heading it will shop the path to your catalog - use this (amend as needed to set a cache directory).

 

Tom

Link to comment
Share on other sites

It needs to be a folder.

 

It doesn't come in the download becuase the default setting is for the servers /tmp directory (which on shared servers is a bad idea becuase the directory is shared between all the users and can also cause problems if SAFE mode is active).

Just create a new directory by any name and use that.

Tom

Link to comment
Share on other sites

  • 2 weeks later...
Ok, so in Admin -> Configuration -> Cache I have got http://www.jemcraftmemories.com/cache

 

But when I click on Admin -> Tools -> Cache Control I still get 'Error: Cache directory does not exist. Please set this Configuration->Cache.'

 

What am I doing wrong?

 

 

That's not your full path. It would be for example /var/www/jemcraftmemories.com/cache with permission on that directory set to 777 most likely.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...