Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Customers having other customer's address show up during order process?


Nikolas

Recommended Posts

I have been receiving phone calls and emails from potential customers saying that another customer's address is auto-populated into the field during the checkout process.

 

I have also received a call from a past customer, that says they have been receiving order confirmation emails for orders they havent placed (orders placed by new customers).

 

Has anyone experienced this?

 

Does anyone know what might be the problem and/or solution?

 

Thanks!

 

Nikolas

Link to comment
Share on other sites

Hi,

I'm just exprienceing the same prob with my own shop.

 

2 clients called me :

- The first one was emailed an order created by an another customer

- the second had his ordered saved with a bad billing addresse and another bad shipping address

 

Did you fond a way to solve this problem ?

 

Thanx

Link to comment
Share on other sites

This is happening to me to, a customer was logged into the site, but I managed to complete a whole transaction paying by cheque using their account, it was just there open for anyone to see.

Link to comment
Share on other sites

This is happening to me to, a customer was logged into the site, but I managed to complete a whole transaction paying by cheque using their account, it was just there open for anyone to see.

Link to comment
Share on other sites

There are a few things that cause this. In your includes/configure.php file, use these settings

  define('USE_PCONNECT', 'false'); 
 define('STORE_SESSIONS', 'mysql');

Be sure to set Prevent Spider Sessions in admin->configuration->Sessions to true. If you are using the logging and/or the cache options, be sure the tmp directory location is one specific to the shop (not a shared one by your host). I may be forgetting some but those are the main ones.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

I will check with your define('STORE_SESSION', 'mysql').

 

My question is : I've used on the application_top.php this instruction :

 

  ini_set("session.save_handler", "files");

 

Actually, Without this line, I encoutered very frequently but randomly this error message :

"Failed to initialize session storage..."

 

Do you think I should comment my ini_set line ?

Link to comment
Share on other sites

I tried the "define", keeping the ini_set...

there is nothing better.

 

But I have more information.

The client experiencing the problem actually try to indentifiy with his email address ans his password...

And that's how he becomes connected under another account.

 

There must have been a problem when he created his account besause I can't see any account correposnding to his name in the admin. And now he believe he can indetify him on the oscommerce shop, and when submitting his email address and password he becomes connected under another name : always the same.

 

Have you ever encouter this weird problem ?

Link to comment
Share on other sites

There are a few things that cause this. In your includes/configure.php file, use these settings
  define('USE_PCONNECT', 'false'); 
 define('STORE_SESSIONS', 'mysql');

Be sure to set Prevent Spider Sessions in admin->configuration->Sessions to true. If you are using the logging and/or the cache options, be sure the tmp directory location is one specific to the shop (not a shared one by your host). I may be forgetting some but those are the main ones.

 

Jack

 

We have a couple of problems with our site at the moment.

 

The first is that a couple of customers are unable to log into their accounts using their e-mail address and passwords. This does not happen to all customers as I have an account and can access it fine. They have tried requesting new passwords using the link, but these do not work either. They cannot create new accounts, as the system tells them they are already registered with that e-mail address!!! Catch 22.

 

Does anyone know why this is occuring?

 

The second problem we have is that when some customers are logged in, items are mysteriuosly removed from their baskets and other items that they haven't even looked at added to their baskets. To make matters worse, I recently managed to complete a cheque transaction on somebody else's account as they were logged into the site whilst I was doing it. It was ony once I finished I realised that I hadn't been asked to log in to complete the transaction - when I checked the admin side, the transaction had been completed using the customer that was logged in details!!!! ARGH!!

 

Site address is: www.jemcraftmemories.com

 

Under sessions I have the following:

 

Sessions

 

Session Directory --- /tmp

Force Cookie Use --- False

Check SSL Session ID --- False

Check User Agent --- False

Check IP Address --- False

Prevent Spider Sessions --- False

Recreate Session --- False

 

Should something be changed here?

 

Thanks

Jemma

Link to comment
Share on other sites

for the 2nd problem you have the spiders indexing your site with sessions. So now when major search engines present the search results to potential customers these links have the session appended. Subsequently clicks from those people all end up to your store using the same session.

 

This switch

Prevent Spider Sessions --- False

 

Should been

Prevent Spider Sessions --- True

 

as it was mentioned earlier.

 

you can also try this:

http://www.oscommerce.com/community/contributions,4112

Link to comment
Share on other sites

I have further information about my probleme of bad addresses in orders :

 

Actually, the customer who try to buy his product (once having selected his items and click on "validate your order") tries to identify him.

 

He types in his email address and his password, and that is where oscommerce logs him under a bad account.

 

Also, I can't see his account in my admin panel. So there are 2 problems in my osCommerce :

- The account registration failed : the customer was told in workes whereas nothing was reated

- And worth : now when he tries to log in, he orders with a bas account.

 

Have any of you had experimeted this before ?

Link to comment
Share on other sites

I was wondering if there could be due to a snapshot I added juste before displaynig the login form...

I don't know exactly what the snapshot does...that's why I ask you...

 

Thanx

Link to comment
Share on other sites

I have further information about my probleme of bad addresses in orders :

 

Actually, the customer who try to buy his product (once having selected his items and click on "validate your order") tries to identify him.

 

He types in his email address and his password, and that is where oscommerce logs him under a bad account.

 

Also, I can't see his account in my admin panel. So there are 2 problems in my osCommerce :

- The account registration failed : the customer was told in workes whereas nothing was reated

- And worth : now when he tries to log in, he orders with a bas account.

 

Have any of you had experimeted this before ?

It sounds to me like you have two accounts that close to the same and the customer is logging into the wrong one. That would explain the problem with the already on file message. Take a look at admin->customers and see if you can find two that are close. Customers are known to type in the wrong informaion and, if it works, they will keep doing it.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Well, theses two people have absolutely nothing in common. They do not live in the same region and what is so weird to me is that I have no clue about where is this customer account.

I can see the account in which he his logged into, but I can't see any account matching my client email address or anything.

 

That's why I'm a bit lost and it's really difficult to me to test my application.

Link to comment
Share on other sites

I was wondering if there could be due to a snapshot I added juste before displaynig the login form...

I don't know exactly what the snapshot does...that's why I ask you...

 

Well, we don't know what it does - you are the one who installed it - and hopefully you didn't install something that you do not know works - or installed without knowing what it does.

 

Vger

Link to comment
Share on other sites

Well, we don't know what it does - you are the one who installed it - and hopefully you didn't install something that you do not know works - or installed without knowing what it does.

 

Vger

 

Actually, I didn't develop the website from scratch. I only worked on a graphic tranformation of the oscommerce shop.

During my tests, I added this snapshot to make "back" buttons working...

 

That's why I don't master perfectly the whole site.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...