Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Register Globals off -- need help!


jpweber

Recommended Posts

Hello. I'm trying to install OSCommerce, and I've done everything they've said until now. When I went to http://store.mydomain.com/install, I got an error message:

 

"FATAL ERROR: register_globals is disabled in php.ini, please enable it!"

 

I made a file called phpinfo.php, and I found out that my Register Globals are set to OFF and OFF, for the Local Value and the Master Value. I talked to a Buzix support representative online, and he was unable to help, so he asked me to submit a help desk ticket.

 

Well, forget this guy. I thought I'd get my own help and come here! Do you know anything I can do?

 

I have read the forums and have found the suggestion that I download this patch/contribution: Register Globals This is a patch that will remove the need to enable 'register_globals' in the php.ini file. In fact, once it is applied,, register_globals MUST be disabled otherwise it will not work ... I found this on the URL http://www.oscommerce.com/community/contri...register_global ...

 

Should I download this, unzip it, and upload it to the root directory?

 

Thank you for anyone who's kind enough to respond,

 

Jason

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

It's easier to paste than to send you to the post...

 

If your site is hosted on a Windows server then you'll have to install the Register Globals Patch (find in Contributions).

 

If your site is hosted on an Apache server with a Unix or Linux Operating system then you may be able to turn on Register Globals just for your website by putting the code below into a .htaccess file in the root of your site.

 

CODE

php_flag register_globals on

 

 

Vger

 

Try that :)

 

Hello. I'm trying to install OSCommerce, and I've done everything they've said until now. When I went to http://store.mydomain.com/install, I got an error message:

 

"FATAL ERROR: register_globals is disabled in php.ini, please enable it!"

 

I made a file called phpinfo.php, and I found out that my Register Globals are set to OFF and OFF, for the Local Value and the Master Value. I talked to a Buzix support representative online, and he was unable to help, so he asked me to submit a help desk ticket.

 

Well, forget this guy. I thought I'd get my own help and come here! Do you know anything I can do?

 

I have read the forums and have found the suggestion that I download this patch/contribution: Register Globals This is a patch that will remove the need to enable 'register_globals' in the php.ini file. In fact, once it is applied,, register_globals MUST be disabled otherwise it will not work ... I found this on the URL http://www.oscommerce.com/community/contri...register_global ...

 

Should I download this, unzip it, and upload it to the root directory?

 

Thank you for anyone who's kind enough to respond,

 

Jason

Link to comment
Share on other sites

I had the same issue and I used the Register_globals_off patch, everything was working fine for me, except I got caught in a loop on Step 2, it seems that everytime I wanted to progress from step2 I looped back to the same page I tried to proceed from. For some reason OSC didn't wanna install on the php5 server I was using, so I wound up switching to php4.4.12 and had no errors with a vanilla install[meaning no modified code using register_globals_off]. so in short:

 

Globals_off patch is the way to go

Watch out for that loop problem on step2 if you run into it, i don't know how that can be resolved

 

P.S. having globals_off is a really good thing, why OSC wasn't designed with globals_off in mind, i have no idea.

We must be the change we wish to see in the world.

------------------------------------------------------------

p.s. BACKUP!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...