Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Major problem, please help!


rustybolt

Recommended Posts

been using this for ages now adding new products etc, all of a sudden i cannot access any pages properly.

 

this comes up on the screen:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /homepages/27/d157718397/htdocs/includes/application_top.php on line 285

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /homepages/27/d157718397/htdocs/includes/application_top.php on line 285

 

 

 

on the line it mentions (285) this is what is there:

 

require(DIR_WS_LANGUAGES . $language . '.php');

 

what is wrong with this line and why now when its worked fine for months and i havent changed anything?/

 

please can some one help

Link to comment
Share on other sites

been using this for ages now adding new products etc, all of a sudden i cannot access any pages properly.

 

this comes up on the screen:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /homepages/27/d157718397/htdocs/includes/application_top.php on line 285

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /homepages/27/d157718397/htdocs/includes/application_top.php on line 285

on the line it mentions (285) this is what is there:

 

require(DIR_WS_LANGUAGES . $language . '.php');

 

what is wrong with this line and why now when its worked fine for months and i havent changed anything?/

 

please can some one help

 

can you post a url

Regards

 

Mark A Reynolds

Link to comment
Share on other sites

been using this for ages now adding new products etc, all of a sudden i cannot access any pages properly.

 

this comes up on the screen:

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /homepages/27/d157718397/htdocs/includes/application_top.php on line 285

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /homepages/27/d157718397/htdocs/includes/application_top.php on line 285

on the line it mentions (285) this is what is there:

 

require(DIR_WS_LANGUAGES . $language . '.php');

 

what is wrong with this line and why now when its worked fine for months and i havent changed anything?/

 

please can some one help

 

Strange, I'm getting the same problem from today as well.

 

our site is at www.yumyumtummyrumble.co.uk

 

It looks like we both use the same hosting comany (one and one) judging from the structure of the error path. Not sure if that is relevant though.....

 

Rob

Link to comment
Share on other sites

Strange, I'm getting the same problem from today as well.

 

our site is at www.yumyumtummyrumble.co.uk

 

It looks like we both use the same hosting comany (one and one) judging from the structure of the error path. Not sure if that is relevant though.....

 

Rob

 

Me too! I'm on one and one as well! they had a problem with their servers yesterday.. maybe they've set them back up differently.. i'm looking into it now - I'll post if i find a solution

 

mike

my sites:

----------

www.preciousmetal-online.co.uk

www.liparazzi.com

www.yaoh.co.uk

Link to comment
Share on other sites

Me too! I'm on one and one as well! they had a problem with their servers yesterday.. maybe they've set them back up differently.. i'm looking into it now - I'll post if i find a solution

 

mike

 

Try changing

define('STORE_SESSIONS', 'mysql');

 

to

 

define('STORE_SESSIONS', '');

 

in includes/configure.php and admin/includes/configure.php

 

Solves the language issue - or seems to..

 

But now i'm getting this error in the admin: :angry:

 

Warning: session_start(): open(SESSION_WRITE_DIRECTORY/sess_cce1df87d906af66876b2b3640abd9bd, O_RDWR) failed: No such file or directory (2) in /homepages/45/d98552183/htdocs/catalog/admin/includes/functions/sessions.php on line 67

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/45/d98552183/htdocs/catalog/admin/includes/functions/sessions.php:67) in /homepages/45/d98552183/htdocs/catalog/admin/includes/functions/sessions.php on line 67

Warning: Cannot modify header information - headers already sent by (output started at /homepages/45/d98552183/htdocs/catalog/admin/includes/functions/sessions.php:67) in /homepages/45/d98552183/htdocs/catalog/admin/includes/functions/administrators.php on line 66

 

Anyone know whats going on?

 

Mike

my sites:

----------

www.preciousmetal-online.co.uk

www.liparazzi.com

www.yaoh.co.uk

Link to comment
Share on other sites

Me too! I'm on one and one as well! they had a problem with their servers yesterday.. maybe they've set them back up differently.. i'm looking into it now - I'll post if i find a solution

 

mike

 

OOPS! :(

Regards

 

Mark A Reynolds

Link to comment
Share on other sites

OOPS! :(

 

OK - think i've found a solution. Ignore my last post - don't do that. It won't work

 

Think it is to do with cached information (maybe they've changed session info or something?)

 

Anyway - if using IE - close all browser windows,

open 1 browser window

tools -> internet options -> clear cache, settings, history, files etc

try again

 

It worked for me - and i can now access both of your shops - no problem :thumbsup:

 

mike

my sites:

----------

www.preciousmetal-online.co.uk

www.liparazzi.com

www.yaoh.co.uk

Link to comment
Share on other sites

OK - think i've found a solution. Ignore my last post - don't do that. It won't work

 

Think it is to do with cached information (maybe they've changed session info or something?)

 

Anyway - if using IE - close all browser windows,

open 1 browser window

tools -> internet options -> clear cache, settings, history, files etc

try again

 

It worked for me - and i can now access both of your shops - no problem :thumbsup:

 

mike

 

Nice one Mike, That's worked for me too. :D

 

Thanks

Rob

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...