Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Site builds great - just one bug to fix, any clues?


TrinityAries

Recommended Posts

Hi,

My site is building great and i have ironed out about 12 minor issues using topics from the forum, but I was unable to see an existing topic covering this error. Can anyone help?

 

At the base of certain pages, the following appears:

 

Error!

 

Unable to determine the page link!

 

You can get this error from any of the following pages:

 

http://arkmodel.eu/estore/contact_us.php/action/send

http://arkmodel.eu/estore/index.php/cPath/22

http://arkmodel.eu/estore/product_info.php/products_id/28

http://arkmodel.eu/estore/index.php/manufacturers_id/10

http://arkmodel.eu/estore/index.php/language/de

http://arkmodel.eu/estore/index.php/language/en

http://arkmodel.eu/estore/index.php/language/es

http://arkmodel.eu/estore/reviews.php/language/de

http://arkmodel.eu/estore/reviews.php/language/en

http://arkmodel.eu/estore/reviews.php/language/es

 

Can anyone see the pattern and of course the fix? I believe it might be something to do with the language / currency columns.

Either way, I would be most happy to hear the cure / fix from anyone who can provide this for me... :rolleyes:

 

Regards,

TrinityAries

Link to comment
Share on other sites

What modification are you using to rewrite your URLs? I'm guessing that the forwardslashes are confusing the shop - would not normally expect to see forwardslashes like this after the file extension:

 

 

You're sure the rewrite commands are correct?

 

Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Link to comment
Share on other sites

Try looking in your admin area at Configuration -> My Store -> Use Search engine safe URLs and make sure it is set to false.

 

Have a look in the contributions area for an alternative SEO URL solution that are much more reliable - there are several threads relating to the pros & cons of each.

 

Tom

Link to comment
Share on other sites

What modification are you using to rewrite your URLs? I'm guessing that the forwardslashes are confusing the shop - would not normally expect to see forwardslashes like this after the file extension:

You're sure the rewrite commands are correct?

 

Terra

 

Sincere thanks!

 

Search Engine Safe URL's was in fact set to True. False cures the issue.

 

Many thanks :D

 

Kind regards,

TrinityAries

Link to comment
Share on other sites

Try looking in your admin area at Configuration -> My Store -> Use Search engine safe URLs and make sure it is set to false.

 

Have a look in the contributions area for an alternative SEO URL solution that are much more reliable - there are several threads relating to the pros & cons of each.

 

Tom

Sincere thanks!

 

Search Engine Safe URL's was in fact set to True. False cures the issue.

 

Many thanks :D

 

Kind regards,

TrinityAries

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...