Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Moved OSC to SSL cert


Guest

Recommended Posts

I created my OSC on a non-secure server. It was moved over to a SSL server and OSC is still looking at the old server and not working. I have the website files (all files) backup and have a backed up OSC .sql file. I renamed my OSC folder to old and had to reinstall OSC 2.2. Went into to the admin panel and restored my .sql backup file but nothing happened.

 

 

What should I do ? I don't have time to re-create my entire catalog.

 

 

 

Thanks in advance.

 

Ckelly

Link to comment
Share on other sites

What is or is not happening that tells you the store is still running on the old server?

 

If you changed hosts, it takes up to 72 hours for a DNS change to propagate.

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

What is or is not happening that tells you the store is still running on the old server?

 

If you changed hosts, it takes up to 72 hours for a DNS change to propagate.

 

OSC comes up but it's all scrambled. Web host technical told me that the OSC is still looking at the old server. This has been 4-5 days now. I re-installed OSC and then restored from back up but that hasn't worked either. I just see the standard install with no new products.

 

 

Thanks

 

Ckelly

Link to comment
Share on other sites

Did you repoint your domain correctly to the dns addresses for the new server?

 

Vger

 

Sites up and running on the ssl server. When I go to OSC I get a non-secure error message. If I say "no" my OSC comes up scrambled. How do I apply my SSL cert to my OSC site ?

 

 

Thanks again for everyones help.

 

Ckelly

Link to comment
Share on other sites

Sites up and running on the ssl server. When I go to OSC I get a non-secure error message. If I say "no" my OSC comes up scrambled. How do I apply my SSL cert to my OSC site ?

Thanks again for everyones help.

 

Ckelly

 

I read up in the osC manual which can be downloaded at from documentation in the solutions pop-down menu in the head nav bar.

 

It says something like you must edit your two configure.php files to enable ssl and osc does the rest for you. But its best you read up in the manual first. it starts around page 79 and includes tips for common ssl errors.

Nick

Talking Is Not Communication - Kubo Tite

yes, i am a bleach fan

and how do you get this automatically added to your footer

Menou and unome

Link to comment
Share on other sites

I read up in the osC manual which can be downloaded at from documentation in the solutions pop-down menu in the head nav bar.

 

It says something like you must edit your two configure.php files to enable ssl and osc does the rest for you. But its best you read up in the manual first. it starts around page 79 and includes tips for common ssl errors.

Nick

Talking Is Not Communication - Kubo Tite

yes, i am a bleach fan

and how do you get this automatically added to your footer

 

Nick: It appears that when ever I click on a link in OSC it goes to http, not https.

 

 

That seems to be the problem. I am reading up with your advice.

 

Thanks for your help.

 

Ckelly

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...