Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Permissions conflict


uberzilla

Recommended Posts

Hello,

 

I am a newb to OScommerce. I have succesfully loaded it.

 

The problem is with the permissions. If I set the permissions for the catalog includes for anything other then 700 - 775 (no security) as opposed to the instructions which say 644 and below all yield the errors below:

 

Warning: main(includes/application_top.php) [function.main]: failed to open stream: Permission denied in

catalogue3/oscommerce-2.2ms2-051113/catalog/index.php on line 13

 

Warning: main(includes/application_top.php) [function.main]: failed to open stream: Permission denied in catalogue3/oscommerce-2.2ms2-051113/catalog/index.php on line 13

 

Fatal error: main() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/local/lib/php') in catalogue3/oscommerce-2.2ms2-051113/catalog/index.php on line 13

 

I contacted my host's tech support and they recommended a setting of 444. This however, as stated above, produces the same resulting errors.

 

Server info:

 

Server OS: Linux

Database: MySQL 4.0.27

HTTP Server: Apache

PHP Version: 4.4.3-dev (Zend: 1.3.0)

 

I will do some testing to see if I can get it, however I am severly pressed for time. If anyone has an answer - my thanks in advance.

Link to comment
Share on other sites

What instructions said to change the permissions on the includes folder to 644?

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

What instructions said to change the permissions on the includes folder to 644?

 

 

You are right. I miss read. It is for the Admin/includes/config.

 

Pg 9 > recommendation for shared server > Rest permission on catalog/admin/includes.

 

Further experimentation showed that 444 setting on the catalog/includes/config did the trick!!! :thumbsup: That is; solved my security problem and allowed the rest to work properly.

 

Now they just need a more exited emoticon here...LOL.

 

Thanks for the speedy response.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...