Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals disabled


zoom4267

Recommended Posts

hello all, i know ive seen this topic before but cant find it... ive downloaded the oscommerce to my webhost and when i try to log in i get

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

 

what do i do now?

 

thank you

 

Lisa

Link to comment
Share on other sites

I was just going to give that same URL.

 

There could be a number of reasons why it isn't working. As well as that patch, it is advisable for you to see what version of php is installed on the server too.

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Link to comment
Share on other sites

I was just going to give that same URL.

 

There could be a number of reasons why it isn't working. As well as that patch, it is advisable for you to see what version of php is installed on the server too.

 

 

 

its phpMyAdmin 2.7.0 pl2

Link to comment
Share on other sites

No.... not phpmyadmin... I am asking about the php version installed on your server.. it's a long shot but if it is something like PHP Version: 4.4.2 (Zend: 1.3.0) and the MySQL is 4+ (but less than 5), then apply the patch link given above it should work.

 

You really need to log in to your admin and click the tools box and then server info - you'll see it there and it will tell you for 100% if your register globals are on or off... yes I know the error that shows but best to see it for yourself in server info

 

Good Luck

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Link to comment
Share on other sites

No.... not phpmyadmin... I am asking about the php version installed on your server.. it's a long shot but if it is something like PHP Version: 4.4.2 (Zend: 1.3.0) and the MySQL is 4+ (but less than 5), then apply the patch link given above it should work.

 

You really need to log in to your admin and click the tools box and then server info - you'll see it there and it will tell you for 100% if your register globals are on or off... yes I know the error that shows but best to see it for yourself in server info

 

Good Luck

 

 

hows this?

MySQL4 4.1.9

 

 

thanks

Link to comment
Share on other sites

.... Yes it should be ok with that version.

 

Just add the contribution and test it before posting your results here.

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Link to comment
Share on other sites

hello all, i know ive seen this topic before but cant find it... ive downloaded the oscommerce to my webhost and when i try to log in i get

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

what do i do now?

 

thank you

 

Lisa

Link to comment
Share on other sites

hello all, i know ive seen this topic before but cant find it... ive downloaded the oscommerce to my webhost and when i try to log in i get

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

what do i do now?

 

thank you

 

Lisa

Link to comment
Share on other sites

You have to edit php.ini and enable register_globals. This is easily done if you have access to it (is in the /etc directory on the Unix/Linux servers), on windows you have to look for it.

 

Just change the line:

 

register_globals = off

 

to

 

register_globals = on

 

in php.ini (or have somebody change it for you). The PHP default is register_globals = off.

 

After this, you should reload your web server to pickup the new php.ini.

 

Carlos

Link to comment
Share on other sites

You have to edit php.ini and enable register_globals. This is easily done if you have access to it (is in the /etc directory on the Unix/Linux servers), on windows you have to look for it.

 

Just change the line:

 

register_globals = off

 

to

 

register_globals = on

 

in php.ini (or have somebody change it for you). The PHP default is register_globals = off.

 

After this, you should reload your web server to pickup the new php.ini.

 

Carlos

 

 

carlos.

 

i looked in the ect folder and i couldnt find the register_globals line.

 

thanks

Link to comment
Share on other sites

carlos.

 

i looked in the ect folder and i couldnt find the register_globals line.

 

thanks

 

 

 

i found it b ut i cant edit it, i dont have the permissions.

 

thanks for all of the help , i contacted my web host.

 

i appreciate all of your help.

 

Lisa

Link to comment
Share on other sites

i found it b ut i cant edit it, i dont have the permissions.

 

thanks for all of the help , i contacted my web host.

 

i appreciate all of your help.

 

Lisa

Hi,

It is up to your host to do it for you.

I had same problem with mine and asked my host to enable it.

Now every things are fine.

OH Boy!!! Not again!!!!!!!!!!!!!!!!!!!!!!

Link to comment
Share on other sites

Hi,

 

My hosting company's all servers have been updated to latest MySQL 5 with PHP 5 (suEXEC support).

 

This is the respond on my email about register_global problem:

 

1. Check your file/folders permissions. PHP/CGI scripts must be set to 755 and regular files to 644. You can also set read/write files to 666. 777 permissions won't work anymore for security reasons.

 

2. Comment out .htaccess settings or delete the .htaccess files. You should create those settings in a php.ini file within each directory you are running php scripts (that have .htaccess files).

 

Please remember: you cannot manipulate the php.ini settings with .htaccess when running PHP as cgi/phpsuexec. If you are using .htaccess with php_value entries within it, you would receive "Internal Server Error" (500) when attempting to access the scripts. This is because PHP is no longer running as an Apache module and Apache will not handle those directives any longer. All PHP values should be removed from your .htaccess files to avoid this issue. Placing a php.ini file in its place will solve this problem.

 

Can u tell me, please, how to create those settings in a php.ini file?

 

Thanks in advance.

Link to comment
Share on other sites

Last year I too received an email about those issues but I didn't change anything. My sites still worked fine.

 

As a result of your post jogging my memory I decided to see what version my server was running and it is 4.18 (instead of 4.4.2)... I guess they must have downgraded as too many hosts are having problems with verison 5+

Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...