Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't finish with the installation process


Tormenta

Recommended Posts

Dear all, I'd desperately need your help on this issue please.

 

I?ve been trying to install osCommerce on my hosting (Network Solutions ? hosting package -windows) (maybe I should?ve chosen Unix ? ?????) for 3 days already and don?t seem to be able to. I?m running Windows XP.

 

I tried to follow Vger instructions (thanks for this!!) and completed steps 1 and 2, that was not a major issue.

 

Step 3. I uploaded the whole of the contents of the catalog folder to the root:/htdocs (by default on the hosting. The support center told me I had to upload it on the htdocs folder) of the website via FTP (FileZilla).

 

And here the mess and my nightmare start.

 

Step 4. In the hosting file manager, root:/htdocs, I see all the osc catalog folders and files. All of them have permissions set, even when I did nothing to set them. Some have ?rwx? permissions, others ?rw? and others no permissions at all. I have no idea of what r, w and x mean and worse, how to change them either. (Network Solutions? FAQs are the most incomplete and unclear I?ve ever seen ? BUT, I have to say that I?m a bit new on this)

 

After surfing for hours and hours looking for information that could take me out from here, I remember I red somewhere that if on a Windows based system, you will not need to change file permissions yet. Is it right? And if so, when am I supposed to change the file permissions?

 

Step 5. Then I go to http://www.mydomain.com/install. And what I get is: ?You have no authorization so see this page ? It might be that you do not have permission to see this directory or page with the credentials provided (sorry, translated from Spanish).

 

And that?s all. I?m stuck here and don?t know where to go, what to do or where to start with in order to be able to finish with the installation.

 

If someone could give me some help, orientation, clue, idea, advise, I would deeply-deeply appreciate it.

 

Many thanks to all of you.

Link to comment
Share on other sites

You would have been better off on an Apache server, but your Windows server should be set up to allow you to install osCommerce.

 

Try going to http://www.yourdomain.com/install/index.php and see if the page will load using the full address.

 

Make sure that beforehand you set up a blank database via your web hosting control panel.

 

Folders should have permissions of 755, which is:

Owner - Read, Write, Execute

Group - Read, Execute

Other - Read, Execute

 

It should show up in FTP as -rwx

 

Files should have permissions of 644 and show up in FTP as -rw-

Owner - Read, Write

Group - Read

Others - Read

 

Except for the two configure.php files which should be 755 for the install, and reset afterwards.

 

Vger

Link to comment
Share on other sites

Many many thanks for your answer Vger. I wish I could answer to you saying it worked but after hours sweating here and trying EVERYTHING to change the permissions it seems that, for who knows which reason, the ?change permissions? function in my hosting is missed. :angry: The technical support service told me this will be solved in the coming hours.

 

I?ll keep you posted, I guess that once it works and with your clear explanation, I should be able to finish with the installation.

 

Thanks a lot!

Link to comment
Share on other sites

Well, finally I changed for a unix package and could manage to finish with the installation!!!!! As other people say, it tool me just 5 minutes and I've been checking here and there and everything seems to work properly up to now. The only thing is that after the installation, I had to reset the permissions of the configure.php files to 777, otherwise it doesn't work. Hope this is not a problem?

 

Thanks a lot Vger!

Link to comment
Share on other sites

Permissions on the configure.php files must not be left at 777 (because that is full permissions for everyone). If they don't work unless they are on 777 then you need to get onto your hosts - who unfortunately don't sound to be too on the ball.

 

Vger

Link to comment
Share on other sites

I could finally get to change the permissions of the configure.php files to 644 and everything works ok.

 

Thank you very much for all your help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...