Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem with cookies! help...


fynger

Recommended Posts

hey,

 

i installed oscommerce and i have been configurating, but a problem ocurred...

when I created a new account, it sent me to the cookie_usage.php page, which says the follow (as you should know):

 

Cookie Usage

 

 

Cookie Privacy and Security

 

 

Cookies must be enabled to purchase online on this store to embrace privacy and security related issues regarding your visit to this site.

 

By enabling cookie support on your browser, the communication between you and this site is strengthened to be certain it is you who are making transactions on your own behalf, and to prevent leakage of your privacy information.

 

We have detected that your browser does not support cookies, or has set cookies to be disabled.

 

To continue shopping online, we encourage you to enable cookies on your browser.

 

For Internet Explorer browsers, please follow these instructions:

 

Click on the Tools menubar, and select Internet Options

Select the Security tab, and reset the security level to Medium

We have taken this measurement of security for your benefit, and apologize upfront if any inconveniences are caused.

 

Please contact the store owner if you have any questions relating to this requirement, or to continue purchasing products

 

it must not be my browser, because I use both IE 6 and Firefox 1.5.0.3. I analised in the Bug Reports session as it was explained here in the forum e followed some tips, but I still couldn't fix this situation, I would like someone to help me because I am desperating.

 

my configure.php is list as:

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.my-domain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.my-domain.com/');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalogo/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalogo/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

ETC

?>

 

in administrator area i have:

 

Session Directory /tmp

Force Cookie Use False

Check SSL Session ID False

Check User Agent True

Check IP Address False

Prevent Spider Sessions False

Recreate Session False

 

Someone can help me to resolve this problem?

thanks

M?rio

Link to comment
Share on other sites

I am also having a similar problem...

 

I have configured and installed Ultimate SEO and it is working perfectly... but to allow every possible conceivable search engine advantage, i have forced cookie use to prevent the Session ID being added to links. This also is working fine. What is not working however, is the Login.

 

I can create new user accounts without problems, but when I try to login as one of the users, login.php forwards me to cookie_usage.php.

 

I have checked, rechecked, and then checked again. application_top.php sets a test cookie to test the status and if it cannot set the test cookie successfully, the user is shown the cookie_usage.php screen assuming the problem is with their browser.

 

I have OSCommerce installed in the root directory of the site, so my Cookie Dir is set to "/./" while the domain is simply "mydomain.com" (mydomain is replaced of course with my site's domain name)

 

I am quite baffled now, and hope that someone else has found a solution or workaround to this problem!

 

Any help will be greatly appreciated.

 

Thanks.

Mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...