Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL Login page wont allow login


rollersright

Recommended Posts

Hi All,

Spent the last few days on this one.

 

My site is working fine(apart from this one last problem), after having to change host from fasthosts to dreamhost to allow me to use SSL on mysite.

 

Basically the issue is every time i try to log in to my account when using SSL it will throw you back to the login page. This works fine in non-SSL mode.

 

Anyone got any ideas. Heres a copy of my configure.php file, just in case i have done something stupid.

 

define('HTTP_SERVER', 'http://www.sportandleisureuk.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://sportandleisureuk.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.sportandleisureuk.com');

define('HTTPS_COOKIE_DOMAIN', 'sportandleisureuk.com');

define('HTTP_COOKIE_PATH', '/cgi');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/pspooner/sportandleisureuk.com/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '');

define('DB_SERVER_PASSWORD', '');

define('DB_DATABASE', '');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

I hope someone can help out

 

Thanks in advance

 

Rollers

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...