Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

3 question


zebraplayer

Recommended Posts

1 & 2 - You need to add a <td width=some value></td> before the <td> for the Search code.

 

3 - body class most likely. But if you are using something like Center Shop, then it could be a different table.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Hmm!

 

I'm not sure I follow you on the solution for 1&2. Here's the code I have:

 

<table border="0" width="90%" cellspacing="0" cellpadding="1" align="center">
 <tr class="headerNavigation">

<td align="left" width="240" class="headerNavigation"><IMG height=1 src="images/spacer.gif" width=8>
<FORM name=quick_find action=advanced_search_result.php method=get>
  <input type="text" name="keywords" size="10" maxlength="25">
  <IMG src="images/spacer.gif" width=8>
	   <INPUT title="Quick Search" type=image alt="Quick Search"
	   src="images/button_search.gif" border=0 name=image>
	   </form></td>

<td align="center" class="headerNavigation"><IMG height=8 src="images/spacer.gif" width=90>

<?php
if (!isset($lng) || (isset($lng) && !is_object($lng))) {
include(DIR_WS_CLASSES . 'language.php');
$lng = new language;
}
if (substr(basename($PHP_SELF), 0, 8) != 'checkout') {
reset($lng->catalog_languages);
while (list($key, $value) = each($lng->catalog_languages)) {
if ($language != $value['directory'] ){
$languages_string .= ' | <a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('language', 'currency', 'action')) . 'language=' . $key, $request_type) . '">' . tep_image(DIR_WS_LANGUAGES . $value['directory'] . '/images/' . $value['image'], $value['name'],'','',' style="vertical-align: middle;" ') . '</a>';
}
}
echo $languages_string;
}
?>
</td>


<td align="right" class="headerNavigation"><?php echo strftime(DATE_FORMAT_LONG,(time()-46800)); ?><IMG height=1 src="images/spacer.gif" width=8></td>
</td>
 </tr>
</table>

 

Where would I put the <td width=value></td>?

 

Also, how would that take care of the white vertical dash?

 

Sorry, I'm very new to all this.

 

Thanks!

 

-zp

Link to comment
Share on other sites

Try changing this

<table border="0" width="90%" cellspacing="0" cellpadding="1" align="center">
 <tr class="headerNavigation">

to

<table border="0" width="90%" cellspacing="0" cellpadding="1" align="center">
<tr>
<td width="20%"></td>
</tr>
 <tr class="headerNavigation">

As for the whilte line, I missed that on my first reply. I thought you were asking how to center it too. It is probably coming from this:

 | 

Remove that and it should be OK.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Well, the vertical aligning solution did not work. It didn't do anything.

 

However the vertical dash is gone. (Thanks for not making me feel dumb about that!)

 

BTW, the problem with the background is fixed. It was like you said.

 

Thanks!

 

-zp

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...