Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cookies NOT turned 'ON' error when they actually are.


dragon5

Recommended Posts

Hello. First, I've searched here and at the Firefox databases to no avail. Problem seemed to start yesterday. All had been working fine until then.

 

When using Firefox to access my store, I am getting the following when attempting to place an item in the cart:

 

'We have detected that your browser does not support cookies, or has set cookies to be disabled.' (cookie_usage.php)

 

This happens both on my 'local' machine and when I'm accessing the online store. I have checked and rechecked all Firefox settings. They appear to be correct. Actually, Firefox will accept and store cookies when I access 'admin', just not when I access the store. This leads me to believe it is not a Firefox issue.

 

Any help would be appreciated.

Thanks

 

ps. ALL Works when using IE. Problem is just in Firefox????

Link to comment
Share on other sites

Please. Really need help/advice with this. Live Shop. I now have discovered that if I set 'Force Cookies' to 'true in admin, everything works correctly. Why has this changed when for the past 3 yrs. the shop has worked fine with 'Force Cookies' set to false?

Thanks

Tom

Link to comment
Share on other sites

Please. Really need help/advice with this. Live Shop. I now have discovered that if I set 'Force Cookies' to 'true in admin, everything works correctly. Why has this changed when for the past 3 yrs. the shop has worked fine with 'Force Cookies' set to false? Although, I still have the problem locally no matter which way 'Force Cookies' is set???

Thanks

Tom

Link to comment
Share on other sites

Please. Really need help/advice with this. Live Shop. I now have discovered that if I set 'Force Cookies' to 'true in admin, everything works correctly. Why has this changed when for the past 3 yrs. the shop has worked fine with 'Force Cookies' set to false? Although, I still have the problem locally no matter which way 'Force Cookies' is set???

Thanks

Tom

 

Local Machine:

 

Current Status; If 'Force Cookies' is set to 'False' in admin. IE and Moz 1.7 work fine. Firefox does not.

 

If 'Force Cookies' is set to 'True' IE, Moz, and Firefox, all give the 'You must have your browser set to accept cookies'

Link to comment
Share on other sites

Just in case you didn't know Bumping Of Posts, to keep your post noticed above others, is against forum rules and disrespectful to other users who also want to get their posts noticed.

 

You can only use Force Cookie Use if your site (local or online) either uses no SSL or has a full SSL cert. It cannot be used with a shared ssl cert.

 

Your configure.php file settings for http_cookie_domain also have to be correct. For a local install this will either be 'localhost' or '127.0.0.1', while for an online install it will either be www.yourdomain.com or just your domain.com (either way there's no http://).

 

Vger

Link to comment
Share on other sites

Just in case you didn't know Bumping Of Posts, to keep your post noticed above others, is against forum rules and disrespectful to other users who also want to get their posts noticed.

 

You can only use Force Cookie Use if your site (local or online) either uses no SSL or has a full SSL cert. It cannot be used with a shared ssl cert.

 

Your configure.php file settings for http_cookie_domain also have to be correct. For a local install this will either be 'localhost' or '127.0.0.1', while for an online install it will either be www.yourdomain.com or just your domain.com (either way there's no http://).

 

Vger

 

Vger, Yes i have read the rules and appreciate the reasoning. This is also a part of the rules:

 

'When no one has replied to a posting you have made, it is recommended to reply in the same thread with more information that may help in resolving the issue '. Which was my intent.

 

I have a full ssl cert.

 

my config files ( online & locally) are setup appropriately. This is one of the reasons why this is so frustrating.

Thank You

Tom

Link to comment
Share on other sites

  • 3 years later...

Vger, Yes i have read the rules and appreciate the reasoning. This is also a part of the rules:

 

'When no one has replied to a posting you have made, it is recommended to reply in the same thread with more information that may help in resolving the issue '. Which was my intent.

 

I have a full ssl cert.

 

my config files ( online & locally) are setup appropriately. This is one of the reasons why this is so frustrating.

Thank You

Tom

 

I'm having the same problem. This problem has occured to me in Firefox 3.5.5 (Mac OS X). But it works in Safari though. By the way, installation is in my localhost

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...