Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Zero prices ?


UncleSteve

Recommended Posts

Been making some address formats to UK specs in these files (as per this thread http://www.oscommerce.com/forums/index.php?showtopic=130454)

 

catalog/includes/languages/english.php

catalog/includes/languages/english.php

catalog/admin/includes/languages/english.php

catalog/includes/modules/address_book_details.php

catalog/includes/modules/address_book_details.php

catalog/address_book_process.php

 

So would not have thought the above would have an effect on the price displayed.

 

Then ran a test (as I had some earlier in the updating of the above list), but now find all my prices are showing 0 (zero). Can even buy stuff and get charged zero!

 

The currecny is for UK sterling with a value of 1 so I would have thought that would have been fine. Perhaps I've changed something in admin to have the above effect?

 

Anyone any ideas of how to make good please?

____________________________________________________________________

____________________________________________________________________

Link to comment
Share on other sites

Just replaced the edited files with my back up files, and I still have the same problem of zero prices, so I must have changed something in Admin.

 

Any guidence please?

____________________________________________________________________

____________________________________________________________________

Link to comment
Share on other sites

Do you have UK set as default currency and have you clicked update currencies?

 

Usually price as 0 usually happens when you delete the defualt currency and do not re-assign one.

 

I think you may also need to change this line

define('LANGUAGE_CURRENCY', 'USD');

in includes/languages/english.php to UK or whatever the code is for your currency

Wendy James

 

Creativity is allowing yourself to make mistakes. Art is knowing which ones to keep.

Link to comment
Share on other sites

Thank you Wendy. :)

 

The problem was a combination of not updating the currency and Switch To Default Language Currency in the MY Store Configuration.

 

I now see the vat/tax is not being worked out in the checkout and in the conformation email, though its shown in setting up new products. :( Can't find the reason for that at present

____________________________________________________________________

____________________________________________________________________

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...