Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

[CONTRIBUTION] Authorize Net AIM module


Recommended Posts

Your configure.php file should have https://9fishsurf.websitesource.com for the https address.






I was able to get it working by adding this to the authorize_aim.php file:

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);


I found this online somewhere when searching on the error message that I kept receiving. This disabled the cert check in cURL. Now I am connecting to Authorize.net and the getting a receipt email (I have this option turned on for debugging). Also I get the proper screen in OSCommerce showing that the order has been processed.


But I still don't have the padlock or a redirect happening to an https URL. Shouldn't I see this since I have SSL enabled?



Link to comment
Share on other sites

Was hoping someone could help me make this contribution work. Right now I'm getting the "This transaction cannot be accepted. - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance."


I'm on godaddy linux hosting, with the High Assurance SSL cert.


I changed the settings under "Direct Response" as instructed in this thread, and followed all the possible fixes but still nothing, so I'm thinking its my settings that's somehow screwed up.


My configure.php file as follows:


define('HTTP_SERVER', 'https://www.jpskin.com');

define('HTTPS_SERVER', 'https://www.jpskin.com');

define('ENABLE_SSL', true);

define('HTTP_COOKIE_DOMAIN', 'www.jpskin.com');

define('HTTPS_COOKIE_DOMAIN', 'www.jpskin.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');



I added the following lines for curl on the authorizenet_aim.php :


curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, 1);

curl_setopt($ch, CURLOPT_PROXYTYPE, $proxy_type);

curl_setopt($ch, CURLOPT_PROXY, "");

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);



Any help you can give is greatly appreciated.

Link to comment
Share on other sites

You don't want to local all of your site down behind https. Search Engines don't give page ranking to https pages, so your http_server address should be http:// and not https://



Link to comment
Share on other sites

OMG I got it to work !!!!

only problem is when they click confirm order it doesnt take them to a successful order page, but back to the payment information page!!! dammit.


how do i make it go to the successful order page after you click confirm order!?!?!


ps. the new testing a.net server is



Hi, how did you get pass the "The merchant login ID or password is invalid or the account is inactive? error?


I couldnt get pass it. Ive tried all the sudgestion found on this thread and from A.net support but i get the same error everytime.



I dont even know if this is relevant to my problem or not but i tried anyway.


- I check and double checked Login and Transaction id, generated new Transaction id

- Set Transaction Verification to 3.1

- I tried using test, secure, and certification.authorize.ne....

- Played around the "Direct Response" settings

- double checked Private SSL and Curl compiled php ssl support

- entering and not entering Response/Receipt URLs

- editing https:// and cookie domain in my configure.php as recommended

- Checked if im only cable of using SIM but A.net says my account is both AIM and SIM

- mixed diffrent setting variation of the above


Please help





Link to comment
Share on other sites

The error message says it all "The merchant login or password is invalid or the account is inactive"




yeah ur right i just found out its inactive.. wonder why they email me saying my account is now active in the 1st place

Edited by technoboy
Link to comment
Share on other sites

As this was an existing account did you change the setting in your Authorize Net account from SIM to AIM?




The previous system was also using AIM. The transaction version is 3.1. I have since completly re-built the site . The first time I tried a test with your contribution, it worked! Now it is failing again although I have made no changes since then. It still takes me back to the payment page.

Link to comment
Share on other sites

Below is what I am getting when processing a a.net AIM card.


Is this a SQL error?


Any thoughts?


1054 - Unknown column 'cc_start' in 'field list'


select customers_id, customers_name, customers_company, customers_street_address, customers_suburb, customers_city, customers_postcode, customers_state, customers_country, customers_telephone, customers_email_address, customers_address_format_id, delivery_name, delivery_company, delivery_street_address, delivery_suburb, delivery_city, delivery_postcode, delivery_state, delivery_country, delivery_address_format_id, billing_name, billing_company, billing_street_address, billing_suburb, billing_city, billing_postcode, billing_state, billing_country, billing_address_format_id, payment_method, cc_type, cc_owner, cc_number, cc_start, cc_expires, cvv_number, currency, currency_value, date_purchased, orders_status,



Link to comment
Share on other sites

Tried everything in this whole thread - I get this error



it doesn't appear that there is an error as nothing is there for why the auth fails. Also no failed transactions (no declined) in the auth.net admin panel/reports.


text in red bar - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance.


I can authorize a transaction on the virtual terminal so my account is good and card is good - SSL works - very discouraged that I can't even begin to figure this out even with all the help in the thread - ZERO progress in 4+ hours - help??



Link to comment
Share on other sites

Sorry - I don't get an SSL error (or don't know how to check for it) - any hints on where to look or who to pay to fix this mess (as it's obviously WAY out of my no skills ability to fix)




Your ssl doesn't work, you're getting no padlock on https pages, and the comodo trust logo even throws up an 'insecure' warning.



Link to comment
Share on other sites

Basically, your connection to Authorize Net has to be SSL (it has to send https headers and not http headers), otherwise you will get the problem you are having now.


Go to any https page (login etc) on your website and in the bottom right of your web browser the small of Earth next to 'Internet' should change to the image of a padlock followed by the image of Earth and the word 'Internet', showing that it is a secure page. But your https pages don't do that.


You do have a full SSL certificate, but it's just not working correctly.


Take a look in the Tips & Tricks forum for a thread by AlanR called "The SSL in osCommerce Guide" which should help you to resolve this problem.



Link to comment
Share on other sites

Has anyone got this mod to work correctly with Yahoo hosting?

I have used the yahoo SSL contribution and added all my files in the ssl directory but im getting the following error:





Goes directly back to the checkout_payment.php page.

have delimeted response to no, field sep at comma and encap char at blank.

Have tested the form url to true and false with no luck.


my configure files are as stated in the yahoo ssl contribution. But that may be what is conflicting with this mod....


I know ssl is working because i can use the cc.php with ssl and it works fine and dandy with processing orders.



any help appreciated thanks!!

Link to comment
Share on other sites

i have installed the module and all appears to have gone fine.


the error i am receiving is the following:


(TESTMODE) This transaction cannot be accepted. - Your credit card could not be authorized for this reason. Please correct any information and try again or contact us for further assistance.


when i take it out of test mode on the authorize.net side i get a page can not be found when returning to the

checkout process, the url looks good.




I am not sure how to proceed, any insight would be great, thanks!



Link to comment
Share on other sites

I have one problem. Everything works exept when I run a transaction to test declines it takes me back to the payment page and spits out the error properly, but if I try to change the card info from that point on it holds onto the old card info.


ie. if I run a transaction as:


Bob Dole


exp date



and when its gets declined as it should, when I get redirected back to the payment page if I enter new info as:


G Bush


exp date



When I get to the confirmation page it still says Bob Dole and the declined card info.


Seems like Confirmation Page is not dumping the globals or something.


Any help would be appreciated.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...