Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Authorize.net not working...


xao

Recommended Posts

I just got the my authorize.net account approved and setup and I am not trying to get it integrated into the shopping cart.

 

I can proceed through the checkout and when I get to the payment information ("checkout_payment.php"), I can enter in all the correct information, then I hit continue and I get to the confirmation ("checkout_confirmation.php") page to review one final time, then I hit confirm order button and it immediately logs me out.

 

Looking at my log files, it appears that some traffic goes to authorize.net, as indicated by the logfile listed below:

 

intranet.one-stop.com - - [01/Mar/2006:18:32:34 -0600] "POST /checkout_confirmation.php HTTP/1.1" 200 4518 "http://www.intotheoven.com/checkout_payment.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7"

64.94.118.193 - - [01/Mar/2006:18:33:32 -0600] "POST /checkout_process.php HTTP/1.1" 302 - "-" "-"

64.94.118.193 - - [01/Mar/2006:18:33:32 -0600] "GET /login.php?osCsid=f60o13itcsif73a89gj6 HTTP/1.1" 200 22143 "-" "-"

 

Anyone have any ideas?

 

I'm still in "testing" mode and I also have entered in my Transaction key...

 

I'm not sure where else to look.

 

Thanks for your assistance!

Link to comment
Share on other sites

Ok, just discovered something odd, I get a confirmation e-mail from both the shopping cart and authorize.net that the credit card was successfully charged.

 

However, like I stated before, on the confirmation page, it just logs your at and puts you at the login screen again.

 

When you do re-login, they items you originally had purchased are still in your shopping cart, so even though the CC was charged, e-mail confirmation sent, it logs you out and does not remove the items from your shopping cart.

 

Thanks.

Link to comment
Share on other sites

where and how do you get a transaction key:?

 

Log into your authorize.net account. Once logged in, click on "Settings and Profile" then click on "Obtain Transaction Key" under the "Security" heading in the middle section.

Link to comment
Share on other sites

Just to let everyone know, I have it working, but I used the Authorize.net + gpg contrib.

 

I have only used in testing mode, not quite ready to try production.

 

Quick question, does anyone know if you can move it out of "test" mode and into "production" but still test with the test CC#'s (4111111111111111) to make sure it still all processes?

 

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...