Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

"Force Cookie Use" Problem!!


olimits7

Recommended Posts

Hello,

 

I set "Force Cookie Use" to true because I want to use cookies and to also get rid of the osCid from the URL.

 

The website seems to work fine except for a small bug.

 

If a customer first logs in and then clicks on a category link it logs the customer out. If only happens in that order because if a customer first logs in then clicks on " Cart Contents" and then clicks on a category link it doesn't log the customer out.

 

I can't seem to figure out why it does this. Can anybody help me out with this??

 

But if I set "Force Cookie Use" to false everything works fine, but I don't want to use the website with the osCid in the URL.

 

 

Thank you,

 

olimits7

Link to comment
Share on other sites

Force Cookie use is not the solution for your problem.

 

If you're seeing the session id in the address bar after a couple clicks your cookie domains are most likely set incorrectly.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

it sounds like you have modded something after this mod has been installed or you may have skipped an install step.

 

Go back to the mod and check the instructions. Sorry i can't be of more help.

I did have a similar problem after i installed this but no contents were being added to the users cart if they added them and then logged in.

 

If you havn't tried this try it and see if you have the same problem

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...