Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems with newsletter contrib


Recommended Posts

http://www.oscommerce.com/community/contributions,1678

 

This is the contrib I installed I fallowed the instructions to the T but I dont know what is wrong.

 

I myself tried to sign up for a newsletter I filled in the the info clicked continue and this error popped up.

 

Warning: Cannot modify header information - headers already sent by (output started at /mnt/web_m/d11/s44/b025debf/www/store/nfoscomm/catalog/includes/classes/snoopy1.class.php:2104) in /mnt/web_m/d11/s44/b025debf/www/store/nfoscomm/catalog/newsletters_subscribe.php on line 73

 

This is the error I get what does this gibrish mean, what needs fixed.

 

To see for yourself here is a link to My Store

 

Please help this is a some what live store.

 

Thanks in advance

Eric

Link to comment
Share on other sites

http://www.oscommerce.com/community/contributions,1678

 

This is the contrib I installed I fallowed the instructions to the T but I dont know what is wrong.

 

I myself tried to sign up for a newsletter I filled in the the info clicked continue and this error popped up.

 

Warning: Cannot modify header information - headers already sent by (output started at /mnt/web_m/d11/s44/b025debf/www/store/nfoscomm/catalog/includes/classes/snoopy1.class.php:2104) in /mnt/web_m/d11/s44/b025debf/www/store/nfoscomm/catalog/newsletters_subscribe.php on line 73

 

This is the error I get what does this gibrish mean, what needs fixed.

 

To see for yourself here is a link to My Store

 

Please help this is a some what live store.

 

Thanks in advance

Eric

 

Try this for me. Open both of those files (actually the first one in the error is, I beleive more vital due to it coming first) ..anyway, check to see if there are ANY blank lines at the end of those file. The VERY last line should have something - ?> or </html> nut NOT blank returns.

 

After you''ve removed them, try again.

 

It's usually the simple stuff that breaks the complex stuff.

 

Henry

My Contributions

 

Henry Smith

Link to comment
Share on other sites

OK I looked at the files clossely and in the snoopy file at the top it only had?>

so i made it like the rest and changed it to

?>php

/*

$Id: snoopy1.class.php,v 1.12 2003/06/17 17:29:44 dgw_ Exp $

 

and in the second file there was a white space in the bootom require(whatever); ?> thats it so I changed it to the way it should be

 

require(whatever);

?>

 

Anyhow it works great now thanks for the help I really appriciate it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...