Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning in admin


djo

Recommended Posts

Hello,

 

I was trying to add a new sub-category, and when I choose the image to upload, and click save, I get a WARNING message. Then when I click my browsers back button, the image is there, with the green banner at the top of the page that says "upload sucessful" (or something like that) and the picture is there were it should be. It's been a while since I've added any categories, so I don't know how long this has been a problem. I did the 11/13 update, with the exeption of the "unable to remove items from cart" fix.

 

Here is the warning message:

 

Warning: move_uploaded_file(): Moved: '/var/tmp/phpdNfMkk' to '/home/joujouba/public_html/images/Detailed Zoom.jpg' in /home/joujouba/public_html/XXX/includes/classes/upload.php on line 97

 

Warning: Cannot modify header information - headers already sent by (output started at /home/joujouba/public_html/XXX/includes/classes/upload.php:97) in /home/joujouba/public_html/XXX/includes/functions/general.php on line 38

 

the XXX is the admin.

 

I've searched for a while and the closest thing I found was in bug reports and that had to do with easy populate, which I don't use.

 

What does this mean, and what could be causing this?

 

Thanks in advance

Link to comment
Share on other sites

Try this:

 

- download and open includes/classes/upload.php

- move the cursor to the very end of the file

- use the backspace key to back up until you reach the >

- save and upload

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Try this:

 

- download and open includes/classes/upload.php

- move the cursor to the very end of the file

- use the backspace key to back up until you reach the >

- save and upload

 

Jack

 

 

There was a space there, but after I removed it, I get the same thing. Also noticed that it shows the image until I click save, and then it says no image available.

 

I forgot to mention, I recently changed servers, I had to reset permissions on some files. Could this be the cause?

 

Thanks for getting back so quick.

Link to comment
Share on other sites

The cause is almost certainly as I mentioned. Did you download the file to edit it or tried to do it on the server? Is the error you are now getting exacatly as before or has the file name changed? This type of problem is common when moving sites since the extra space gets added by some ftp programs. The fix is usually as I mentioned.

 

As a test, you could replace the file that is getting the error with the one from the oscommerce archive. If the error goes away, then the problem still exists in that file.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...