Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Nothing Happens When I Edit *.php Files


Guest

Recommended Posts

For some reason I am not able to successfully edit the .php pages.

 

I have edited the text in /languages/english/*.php files and it just shows the old text - not the new text I have added.

 

When I check the files, I see that everything is saved perfectly as I wrote it but for some reason it still shows the old text.

 

Just to see what would happen, I chmod'd the files to 777 and nothing - nada...

 

Anyone have any ideas?

Link to comment
Share on other sites

For some reason I am not able to successfully edit the .php pages.

 

I have edited the text in /languages/english/*.php files and it just shows the old text - not the new text I have added.

 

When I check the files, I see that everything is saved perfectly as I wrote it but for some reason it still shows the old text.

 

Just to see what would happen, I chmod'd the files to 777 and nothing - nada...

 

Anyone have any ideas?

 

 

go to the pages in question and use the ctrl f5 keys to do a forced refresh to make sure you are not looking at a cached version of the pages.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Thanks for replying :)

 

Yes, I have already done a hard refresh (ctl + F5) and have checked that my text is not at the bottom of the page; it isn't.

 

I have modified the shipping arrangements with the Multiple Flat Rate mod and that worked just great.

 

I am at a total loss. I have some intermediate experience with PHP and this is just so frustrating!

Link to comment
Share on other sites

Thanks for replying :)

 

Yes, I have already done a hard refresh (ctl + F5) and have checked that my text is not at the bottom of the page; it isn't.

 

I have modified the shipping arrangements with the Multiple Flat Rate mod and that worked just great.

 

I am at a total loss. I have some intermediate experience with PHP and this is just so frustrating!

 

 

Try deleting the language files before you upload the new version just to be positive that your site is using the new version.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Have you made a back-up of the entire catalog folder within the root?

 

If you have and you are working on the back-up, all the links will point to the original catalog folder. Giving the impression nothing has changed.

Link to comment
Share on other sites

I did backup the DB this morning before I started, but I have been working on the 'live' pages and not the backup.

 

Should I mess with the backup pages, ya think?

Link to comment
Share on other sites

If you have been working on the original and it is on its own, I don't know where your problem lies. However, if you have a back-up of the original catalog directory, in the same place as the original, that could be where the confusion is.

Link to comment
Share on other sites

I just want to say thank you so much for helping me!

 

Okay, now that I have that off my chest... ;)

 

My backup (the standard one that osC offers in the admin panel) is located on the remote server.

 

Earlier after you mentioned that, I deleted the backup from the osC admin panel and none of the backup files are showing in the file manager.

 

Now, I just bought this site from someone off eBay and they haven't given me the switch info for the domain yet... I'm wondering if maybe this site isn't being mirrored somewhere else...

 

That is the only explanation I can come up with because the files I edited (namely the /languages/english/shipping.php) are still showing as pre-edited...

 

What's equally weird is the fact that I changed the shipping module this morning with the Multiple Flat Ship mod and that worked fine. [?!?]

Link to comment
Share on other sites

Okay! I fixed it.

 

It turns out that after a search for every file named 'shipping' on my site, I found a duplicate shipping.php in the includes file. I didn't even think to look there.

 

Thank you spax for your help. :)

Link to comment
Share on other sites

I just want to say thank you so much for helping me!

 

Okay, now that I have that off my chest... ;)

 

My backup (the standard one that osC offers in the admin panel) is located on the remote server.

 

Earlier after you mentioned that, I deleted the backup from the osC admin panel and none of the backup files are showing in the file manager.

 

Now, I just bought this site from someone off eBay and they haven't given me the switch info for the domain yet... I'm wondering if maybe this site isn't being mirrored somewhere else...

 

That is the only explanation I can come up with because the files I edited (namely the /languages/english/shipping.php) are still showing as pre-edited...

 

What's equally weird is the fact that I changed the shipping module this morning with the Multiple Flat Ship mod and that worked fine. [?!?]

 

 

The backup in the osC admin does not backup your files, all it backs up is your database...

 

If you want to backup your files locally ( and you should) then you will need to ftp them to your local computer

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...