Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation Config fails to progress


Guest

Recommended Posts

Greetings,

 

Installing on my own server (Linux 2.6, apache 2, php 5, mysql 4) - have full access to all files.

 

Database is created, user created, files in proper directory, Open the link http://<myserver>/catalog/install and then click on the 'Install' option.

 

Got the 'Register_globals' warning - so added a <Directory "/path/to/osCommerce">php flag register globals on</Directory> (not exact, don't copy that!) to httpd.conf. I've other aps on this server that must have register_globals off. This allows register_globals to be on for osCommerce, and off for everything else. Same as an .htaccess, but being in httpd.conf, it's read at daemon startup instead of on each directory access. Avoids a performance hit, according to apache.org docs. Restarted httpd to impliment change.

 

Re-tried the install/config and it now continues on to the "install or upgrade" page. Clicked 'install'.

 

Get the next page with the 2 check marked boxes - leave 'em checked as per install PDF- click 'Continue', looks like data runs back and forth between browser and server, but the page never changes. Just reloads the same page with the 2 check marked boxes.

 

Entire osCommerce directory is r/w by apache.

 

Installed from the MS2 downloaded yesterday.

 

Suggestions?

TIA!

Link to comment
Share on other sites

Greetings,

 

Installing on my own server (Linux 2.6, apache 2, php 5, mysql 4) - have full access to all files.

 

Database is created, user created, files in proper directory, Open the link http://<myserver>/catalog/install and then click on the 'Install' option.

 

Got the 'Register_globals' warning - so added a <Directory "/path/to/osCommerce">php flag register globals on</Directory> (not exact, don't copy that!) to httpd.conf. I've other aps on this server that must have register_globals off. This allows register_globals to be on for osCommerce, and off for everything else. Same as an .htaccess, but being in httpd.conf, it's read at daemon startup instead of on each directory access. Avoids a performance hit, according to apache.org docs. Restarted httpd to impliment change.

 

Re-tried the install/config and it now continues on to the "install or upgrade" page. Clicked 'install'.

 

Get the next page with the 2 check marked boxes - leave 'em checked as per install PDF- click 'Continue', looks like data runs back and forth between browser and server, but the page never changes. Just reloads the same page with the 2 check marked boxes.

 

Entire osCommerce directory is r/w by apache.

 

Installed from the MS2 downloaded yesterday.

 

Suggestions?

TIA!

 

Go to the php.ini file and unable the extension php_mysql.dll. Restart.

Make sure that the php_mysql.dll file is at the c:\php .

Link to comment
Share on other sites

I installed OScommerce today, and I've got the same problem....

 

I use a local web server Apache 2.0.55 , php 5.1.2 an mysql 5.0.11 on win XP. i work on localhost (the webserver is'nt on-line in internet, only in LAN for testing purpouse)

I've managed to get work the php support, and enabled the extension php_mysql.dll.

I've copied the directory "catalog" and "extras" in htdocs

in mySQL i've created an account (whit full privileges) an a new database "oscommerce" (eventually, i've also imported the oscommerce.sql script)

It load the page install.php but don't do absolutly nothing klikking on "continue" button....

 

what'up!!!

help plz, and THANK YOU ALL!!!!

Link to comment
Share on other sites

The most common cause for installation getting stuck in step 2

is that most recent PHP installations have register_long_arrays = OFF

This needs to be turned to ON in the php.ini file (you will need to

stop and restart your server to get this change to take effect.)

 

Vger

Link to comment
Share on other sites

The most common cause for installation getting stuck in step 2

is that most recent PHP installations have register_long_arrays = OFF

This needs to be turned to ON in the php.ini file (you will need to

stop and restart your server to get this change to take effect.)

 

Vger

 

I also get this fatal erro:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I have my own server but I'm a bit of a surface user. Im not sure how to find my php.ini file to enable. I have putty but have no clue how to use it :P Any noobie assistance would be awesome.

 

Thanks in advance.

Link to comment
Share on other sites

If by "my own server" you mean an offline server (Intranet) then you'll find the php.ini file (most likely) in C:/Windows.

 

If this is an online server (Internet) and you don't know how to use Putty for SSH access then you are really way out of your depth in trying to run your own server. However, provided you can FTP to your server then you should still be able to download php.ini and edit it offline in a plain text editor.

 

Vger

Link to comment
Share on other sites

If by "my own server" you mean an offline server (Intranet) then you'll find the php.ini file (most likely) in C:/Windows.

 

If this is an online server (Internet) and you don't know how to use Putty for SSH access then you are really way out of your depth in trying to run your own server. However, provided you can FTP to your server then you should still be able to download php.ini and edit it offline in a plain text editor.

 

Vger

 

by "my own' I mean a dedicated server and I used plesk as my admin panel. Im more of a surface user I suppose.

 

Ill try FTP to my server. hopefully that will work

 

Thanks for the quick response

Link to comment
Share on other sites

Go to the php.ini file and unable the extension php_mysql.dll. Restart.

Make sure that the php_mysql.dll file is at the c:\php .

 

Sorry franco,

 

Linux not only dosn't have or use *.dll files - there's not even a C: drive you can hang a \php directory hang'n off of <g>. Your suggestions may well be valid for a Windows install - but don't apply for *nix.

 

Thanks though.

Link to comment
Share on other sites

The most common cause for installation getting stuck in step 2

is that most recent PHP installations have register_long_arrays = OFF

This needs to be turned to ON in the php.ini file (you will need to

stop and restart your server to get this change to take effect.)

 

Vger

 

WhooHoo!!

 

That did it Vger - thanks!

 

I added the following to my /etc/httpd/conf/httpd.conf file. Eliminated the need for an .htaccess file.

 

<Directory "/var/www/html/catalog">
php_flag register_globals on
php_flag register_long_arrays on
</Directory>

 

Like I said, I've other apps on this server that can *not* have these options enabled - this limits the required settings to the oscommerce app very nicely.

 

Thanks for the help!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...