Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

IIS white screen . . .


elfnmajic

Recommended Posts

Im running the latest OSC 2.2M2 build on IIS6 PHP 5.12:

 

Everything works fine when it's installed to a subdirectory off of root like \catalog\ with configure.php

 

define('HTTP_SERVER', 'http://www.foo.us/');

define('HTTP_COOKIE_DOMAIN', 'foo.us');

define('HTTP_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');

 

If I copy the entire OSC from /catalog/ to root or / using this configure.php

 

define('HTTP_SERVER', 'http://www.foo.us/');

define('HTTP_COOKIE_DOMAIN', 'foo.us');

define('HTTP_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');

 

I get a white screen with php error:

 

PHP Warning: require(includes/configure.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in C:\includes\application_top.php on line 29

PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/configure.php' (include_path='.;C:\php\pear;c:\php\includes;c:\php\extensions;c:\php;') in C:\includes\application_top.php on line 29

 

Suggestions?

 

Thanks

John

 

BTW Admin and database functions perfectly in both cases.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...