Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: I am able to write to the configuration file


lacuna

Recommended Posts

Warning: I am able to write to the configuration file: /shop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

This message appears at site? will someone lend a hand, thanks.

Link to comment
Share on other sites

Warning: I am able to write to the configuration file: /shop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

This message appears at site? will someone lend a hand, thanks.

 

 

You will need to remove the write permissions from the file set the permissions to either 444 or 644 depending on your server settings.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Yes I tried that already. But when I changed the permission, it went back to the old one as soon as I tried to load the page. So I thought that osCommerce change it.

 

 

I'm having the same difficulty.....it wont change.....but if I try to access the file it is locked out..

but that stupid error is still showing up on the top >_<

 

DJBXP

Link to comment
Share on other sites

Same issue here. Mine is on IIS and windows 2000. I have even tried adding the DENY WRITE permission to the iusr for this file. Still get the error. Im tearing my hair out here!!!!!

 

Not sure the underlying issue, but if you are certain the file is not writable, you can change the includes/application_top.php file at the bottom of the file from:

 

define('WARN_CONFIG_WRITEABLE', 'true');

 

to

 

define('WARN_CONFIG_WRITEABLE', 'false');

 

and the warning will go away. Do at your own risk.

Link to comment
Share on other sites

when you go into your control panel.. follow this path shoppingcart/includes/configure.php click the word not the file.. then on the right click change permissions, and uncheck the box beside write. this should change your #'s. Mine changed to 444 then click to save it...

 

 

Lee Ann

Link to comment
Share on other sites

  • 2 weeks later...

Has anyone got it right? My site is having the same problem. But it's started fine, when i first install it. Only recently this problem came out. Could it my hosting problem?

 

Thanks, Kevin

Link to comment
Share on other sites

Resolved, just followed what leeann said. If your hosting support cpanel, login and go to file manager. Look for the file in your folder which said configure.php and change permission to 644 or 444. Mine require 444 to work. I try ftping to my server and it's already 644 and still there's a warning. I had to put it to 444 and the problem resolved.

 

Thanks

Kevin

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...