Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Newsletter and html


Qvomos

Recommended Posts

Hello everybody,

Perhaps someone can shed some light on this issues:

 

This is the first time I have attempted to use these functions. I've been all day with tech support from the my hosting company trying to fix this issue: The sendmail feature does not send mails in html format. Only in plain text: My settings as of now are:

 

E-mail transport method: sendmail

E-mail linefeeds: LF

Use MIME HTML when sending e-mails: True

Send e-mails: True

 

Also the Newsletter system is out of wack: When previewing the Newsletter (in html format) everything is out of place. Impossible to send such a terrible looking page to my customers.

 

Thank you for any input on this.

 

Jayme

Link to comment
Share on other sites

open file admin/mail.php go to line 42

$mimemessage->add_text($message);

change to

$mimemessage->add_html($message);

 

newsletter

open file admin/includes/modules/newsletteres/newsletter.php

go to line 63

$mimemessage->add_text($this->content);

change to

$mimemessage->add_html($this->content);

 

tell me if it works.

Link to comment
Share on other sites

Hi,

 

I had the same problem. Changed it as described above and not it works on my development server using SMTP.

But the same fix did not work for my live server (admin settings are the same) using sendmail.

 

The email just shows the HTML code :-(

 

Any idea?

Link to comment
Share on other sites

Well, I made the changes that Qihun suggested (thank you very much) and also the one that Eric_SIN suggested (thank you also) I tested the sendmail system. Fisrt of all, I can still not see the preview of the e-mail in html format. I do receive it in html, however, it is completely all over the place, tables, cells, links etc. It is completely useless, I can not possibly e-mail something like that to my customers.

I have the impression that if I use the Nesletter module the same thing will happen with it's html.

I went as far as doubting my html code, wich I think I am pretty good at so I went ahead and saved a browser page from osCommerce (the login/register page) and used that as a test. Still the same result.

Link to comment
Share on other sites

  • 3 years later...
..... stupid..... found the error.

The product_notification.php has to edited as well in oder to allow html product notifications. now it works.

I know this was a while ago but what did you change in product_notification.php ?

Link to comment
Share on other sites

I know this was a while ago but what did you change in product_notification.php ?

 

Just do a search for $mimemessage->add_text

 

replace with $mimemessage->add_html

 

not sure if it'll still work though haven't been able to get sendmail or smtp working with my new host.

Link to comment
Share on other sites

  • 3 weeks later...
open file admin/mail.php go to line 42

$mimemessage->add_text($message);

change to

$mimemessage->add_html($message);

 

newsletter

open file admin/includes/modules/newsletteres/newsletter.php

go to line 63

$mimemessage->add_text($this->content);

change to

$mimemessage->add_html($this->content);

 

tell me if it works.

 

 

WOW - glad to report that this works

Link to comment
Share on other sites

  • 1 year later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...