Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't connect to MySQL server when trying to access admin


visi

Recommended Posts

I get the following error message when I try to access admin/index.php

 

Warning: mysql_connect(): Can't connect to MySQL server on 'localhost' (10061) in D:\inetpub\energyfitnesscoaching\catalog\admin\includes\functions\database.php on line 19

Unable to connect to database server!

 

thanks!

Link to comment
Share on other sites

I get the following error message when I try to access admin/index.php

 

Warning: mysql_connect(): Can't connect to MySQL server on 'localhost' (10061) in D:\inetpub\energyfitnesscoaching\catalog\admin\includes\functions\database.php on line 19

Unable to connect to database server!

 

thanks!

 

Is your catalog section working? If so take the database info from your

 

includes/configure.php file and compare it to the database info in your

 

admin/includes/configure.php file and change the admin info to match. ( you could just copy and paste the whole section)

 

If neither is working then you need to find out what info you have in the files is incorrect and correct it.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Check your admin/includes/configure.php file. It's a favourite problem on Windows servers that the admin/includes/configure.php file doesn't get any info written into it during the install.

 

Vger

Link to comment
Share on other sites

Check your admin/includes/configure.php file. It's a favourite problem on Windows servers that the admin/includes/configure.php file doesn't get any info written into it during the install.

 

Vger

 

What am I looking for? I opened the file in a text editor.

Link to comment
Share on other sites

Is your catalog section working? If so take the database info from your

 

includes/configure.php file and compare it to the database info in your

 

admin/includes/configure.php file and change the admin info to match. ( you could just copy and paste the whole section)

 

Vger

Link to comment
Share on other sites

Vger

 

No, my catalog is not working either. When I go to where the catalog should be I get looped back to the installation screen. When I go to admin I get the Warning message posted at the start of this thread.

 

I ran through the installation again, and got this error message (I also got this previously, but since it's says successful at the end, I didn't post this info):

 

--

Warning: fopen(D:/inetpub/energyfitnesscoaching/catalog/includes/configure.php): failed to open stream: Permission denied in D:\inetpub\energyfitnesscoaching\catalog\install\templates\pages\install_7.php on line 209

 

Warning: fputs(): supplied argument is not a valid stream resource in D:\inetpub\energyfitnesscoaching\catalog\install\templates\pages\install_7.php on line 210

 

Warning: fclose(): supplied argument is not a valid stream resource in D:\inetpub\energyfitnesscoaching\catalog\install\templates\pages\install_7.php on line 211

 

Warning: fopen(D:/inetpub/energyfitnesscoaching/catalog/admin/includes/configure.php): failed to open stream: Permission denied in D:\inetpub\energyfitnesscoaching\catalog\install\templates\pages\install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid stream resource in D:\inetpub\energyfitnesscoaching\catalog\install\templates\pages\install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid stream resource in D:\inetpub\energyfitnesscoaching\catalog\install\templates\pages\install_7.php on line 261

 

 

The configuration was successful!

--

 

thanks.

Link to comment
Share on other sites

You will need to go to your web hosting control panel and use the File Manager to change permissions on both the configure.php files - try 706 first, then 755, and if that doesn't work then try 777. Once the install is successful then reset permissions on both those files to 644 (should be the right setting for Windows servers).

 

I'm sorry you're having this much trouble - but it's really down to the Windows server. My view of them is that if Windows servers were people they wouldn't be able to find their own way home in the dark.

 

Vger

Link to comment
Share on other sites

You will need to go to your web hosting control panel and use the File Manager to change permissions on both the configure.php files - try 706 first, then 755, and if that doesn't work then try 777. Once the install is successful then reset permissions on both those files to 644 (should be the right setting for Windows servers).

 

I'm sorry you're having this much trouble - but it's really down to the Windows server. My view of them is that if Windows servers were people they wouldn't be able to find their own way home in the dark.

 

Vger

 

Wanted to let you know I changed the file permissions and got it all up & running. Thanks!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...