Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

setting user permissions


Guest

Recommended Posts

I am having some problems getting one of the error messages off of the top of the screen:

 

...catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

I have already read through the threads on the forum on what could cause this. Here is what I did:

 

Transfer the catalog folder to the FTP site (using SmartFTP).

Set the permissions on the both configure files to 777 before install.

Complete install and then reset permissions to 644 after install (444 does not work either), as well as deleting the install directory and setting all other permissions.

 

Error message is still there. Is there anything else that would cause this error message?

 

Thanks for the help

Link to comment
Share on other sites

I am having some problems getting one of the error messages off of the top of the screen:

 

...catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

I have already read through the threads on the forum on what could cause this. Here is what I did:

 

Transfer the catalog folder to the FTP site (using SmartFTP).

Set the permissions on the both configure files to 777 before install.

Complete install and then reset permissions to 644 after install (444 does not work either), as well as deleting the install directory and setting all other permissions.

 

Error message is still there. Is there anything else that would cause this error message?

 

Thanks for the help

 

Try changing the permissions from the file manager in your hosting control panel. Some server setups preclude you changing them with your ftp program.

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Try changing the permissions from the file manager in your hosting control panel. Some server setups preclude you changing them with your ftp program.

 

I tried this and it still didn't work. My server is hosted by register.com. Could this have anything to do with it? Supposedly people have set up osCommerce on register.com servers before, but I still not able to do anything. I have tried both 444 and 644 on both of the configure.php files. Anyone else have any other ideas for the cause of this error message?

 

Thanks

Link to comment
Share on other sites

Anyone have any other ideas?

 

 

Have you asked your hosting company?? Tell them you are having trouble changing permissions and see what they have to say

The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Link to comment
Share on other sites

Have you asked your hosting company?? Tell them you are having trouble changing permissions and see what they have to say

 

Yeah I told them I was having trouble and they said they could help me change the permissions, but they couldn't help me with the osCommerce software because it is not their software. Unfortunately, all the permissions are set correctly, so they are unable to help me with anything. I have repeatedly checked the permissions on all the files and they are all correct. Could this problem be caused/solved by any of the .htaccess files?

Link to comment
Share on other sites

If you're sure the setting is for 644, 444 or any setting that does not permit world write turn off the warning.

 

includes/application_top.php at the bottom.

 

// set which precautions should be checked

define('WARN_INSTALL_EXISTENCE', 'true');

define('WARN_CONFIG_WRITEABLE', 'true');

define('WARN_SESSION_DIRECTORY_NOT_WRITEABLE', 'true');

define('WARN_SESSION_AUTO_START', 'true');

define('WARN_DOWNLOAD_DIRECTORY_NOT_READABLE', 'true');

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...