Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Email sending problem.. cant figure out


Guest

Recommended Posts

Hello all... I really searched thru the forums on this one and also thru my smtp softwares docs but I really cant find an answer for this.

 

I can not send out emails from OSCommerce when a customer tries to complete an order. I get the following response from the server:

 

Warning: mail() [function.mail]: SMTP server response: 501 5.5.4 Invalid Address in C:\SITE\watch\catalog\includes\classes\email.php on line 520

 

However, if I go into the admin pannel -> tools -> send email... it works just fine. I get every email I send from there. So my best guess is that its not my SMTP? I'm at a loss right now.

 

I am using MailEnable as my SMTP software.

 

Thanks for any ideas on this one.

 

 

Derek

Link to comment
Share on other sites

Never mind.. realized i dont have it set in php.ini since i moved servers. Sorry :-"

 

 

Ok nevermind my never mind.. im still getting that error....

 

From my research, 501 is a syntax error in whatever is being passed to SMTP. Is there a problem with email.php?? I haven't modifyed it at all.

 

 

Derek

Link to comment
Share on other sites

Ok nevermind my never mind.. im still getting that error....

 

From my research, 501 is a syntax error in whatever is being passed to SMTP. Is there a problem with email.php?? I haven't modifyed it at all.

Derek

 

Bah.. dont ask me why but my ISP was suddenly port blocking 25. Managed to shift the port and now all is working. Go figure.

 

 

Derek

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...