Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals disabled


eli79g

Recommended Posts

Hi,

I've the problem with the installation.

I've upload the folder "catalog" to my server via FTP.

When I try to go to http://myserver.it/catalog/install this is the message:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

The file php.ini is the file named ".htaccess"?

 

What I do modify? How can I enable the register_globals?

 

Thank you for your help!!

elisabetta

Link to comment
Share on other sites

you need this line:

 

php_flag register_globals 1

 

 

you may also need this:

 

php_flag register_long_arrays 1

 

 

beware register_globals on is regarded a possible security risk by many php developers apparently it's being removed in version 3 and the latest osC has a patch to limit the security risk.

Link to comment
Share on other sites

you need this line:

 

php_flag register_globals 1

you may also need this:

 

php_flag register_long_arrays 1

beware register_globals on is regarded a possible security risk by many php developers apparently it's being removed in version 3 and the latest osC has a patch to limit the security risk.

 

 

i am having the same problem, could somebody tell me where exactly i need to put the above codes.

 

i can not access anything: my website or admin.

Link to comment
Share on other sites

:blink: im totaly lost in this matter too..

 

on other forums they strongly recomend that you do NOT chance that...

 

but HOW do i go past this.. i tried to add those lines in htaccess but it didnt work :huh:

Link to comment
Share on other sites

:blink: im totaly lost in this matter too..

 

on other forums they strongly recomend that you do NOT chance that...

 

but HOW do i go past this.. i tried to add those lines in htaccess but it didnt work :huh:

 

 

 

Just add into httpd.conf then restart the apache..

Link to comment
Share on other sites

""Just add these line onto httpd.conf or onto vhost.conf if you are using virtual host""

 

But where I can find that file?

 

I modify the file .htaccess but it didn't work.

 

Thank you for your help.

Link to comment
Share on other sites

""Just add these line onto httpd.conf or onto vhost.conf if you are using virtual host""

 

But where I can find that file?

 

I modify the file .htaccess but it didn't work.

 

Thank you for your help.

 

you'll find it in apache directory

Link to comment
Share on other sites

Sorry,

if I try to connect to www.mydomain.it/catalog this is the message:

 

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

Somebody can tell me exactely what I can modify in the .htaccess file?

Thank you for youe help!

 

elisabetta

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...