Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

probs with froogle and database


Guest

Recommended Posts

i have installed osc ms2 and update i have also installed Seach Engine Friendly URL V1.8 contrib and that all works fine, but ive tried to install the froogle contrib and i get

 

: SQL error Unknown column 'products.manufacturers_id' in 'on clause'| sql = SELECT concat( 'http://www.vikingpcs.co.uk/product_info.php?products_id=' ,products.products_id) AS product_url, products_model AS prodModel, products_weight, manufacturers.manufacturers_name AS mfgName, manufacturers.manufacturers_id, products.products_id AS id, products_description.products_name AS name, products_description.products_description AS description, products.products_quantity AS quantity, products.products_status AS prodStatus, FORMAT( IFNULL(specials.specials_new_products_price, products.products_price) * 1,2) AS price, CONCAT( 'http://www.vikingpcs.co.uk/images/' ,products.products_image) AS image_url, products_to_categories.categories_id AS prodCatID, categories.parent_id AS catParentID, categories_description.categories_name AS catName FROM categories, categories_description, products, products_description, products_to_categories left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id ) left join specials on ( specials.products_id = products.products_id AND ( ( (specials.expires_date > CURRENT_DATE) OR (specials.expires_date = 0) ) AND ( specials.status = 1 ) ) ) WHERE products.products_id=products_description.products_id AND products.products_id=products_to_categories.products_id AND products_to_categories.categories_id=categories.categories_id AND categories.categories_id=categories_description.categories_id ORDER BY products.products_id ASC

 

apear on the froogle.php page now

 

any ideas on whats wrong much apreciated or ways to fix this?

btw ive tryed using the froogle contrip on the install b4 adding any other contrib and it still does the same

please help

Link to comment
Share on other sites

ok i have found if i edit the froogle.php on this line

 

left join manufacturers on ( manufacturers.manufacturers_id = products.manufacturers_id )

 

and chang it to

 

left join manufacturers on ( manufacturers.manufacturers_id = MANUFACTURERS.manufacturers_id )

 

then it gets rid of the error so is there a way round this? do i need to run some code on the database or something?

 

Forgot to mention im using sql 5 if thats the problem? even though i did the edits in the 113update file

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...