Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals disabled - cant log in


sfl

Recommended Posts

Hi,

I am new to bluehost, and I installed Oscommerce using the tool provided and this is the error I receive

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

I changed the permissions in both of these files, but no luck! What am I missing?

 

Thank you in advance.

K.

Link to comment
Share on other sites

'Permissions' on files, meaning the level of access allowed, has nothing to do with Register Globals. Register Globals is a setting in php.ini which is either set to 'On' or 'Off'. Unless you have a dedicated server of your own you won't have access to the main php.ini file - but you may have access to a local php.ini file, and also to a .htaccess file in the root of your domain. The problem is that some server setups will allow you to turn on Register Globals via a local php.ini file or via .htaccess - but some server setups will not allow you to do so.

 

Vger

Link to comment
Share on other sites

'Permissions' on files, meaning the level of access allowed, has nothing to do with Register Globals. Register Globals is a setting in php.ini which is either set to 'On' or 'Off'. Unless you have a dedicated server of your own you won't have access to the main php.ini file - but you may have access to a local php.ini file, and also to a .htaccess file in the root of your domain. The problem is that some server setups will allow you to turn on Register Globals via a local php.ini file or via .htaccess - but some server setups will not allow you to do so.

 

Vger

Thank you. So, does this mean it is left in the hands of the hosting company? I emailed them, yesterday- no response yet.

I checked both files and they are both set to "on"

Sorry.. newbie

Link to comment
Share on other sites

To find out if the master php.ini file is overriding any local settings just go to your osC admin panel --> Tools - Server Info, and search for Register Globals - if it says 'Off' then they're off.

 

There are other options, the Register Globals Patch Files (link below my name - but not tested with the updated MS2), or with the original Register Globals Patch - both are available in Contributions.

 

Vger

Link to comment
Share on other sites

To find out if the master php.ini file is overriding any local settings just go to your osC admin panel --> Tools - Server Info, and search for Register Globals - if it says 'Off' then they're off.

 

There are other options, the Register Globals Patch Files (link below my name - but not tested with the updated MS2), or with the original Register Globals Patch - both are available in Contributions.

 

Vger

Hi Vger... I can not get into the Admin control panel. It is where I enter the username and password that I get the error.

Link to comment
Share on other sites

  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...