Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Shared SSL Images Not Showing


DawnG

Recommended Posts

I am running www.pagan-magic.co.uk/shop on osCommerce version 2.2ms2 on the following server:

 

Linux

Apache Version 1.3.33 (Unix)

PHP Version 4.4.1

 

The hosting company has a shared secure area which can be accessed by referring to:

 

https://secure.avdns6.com/~username

 

By following the forum advice I have changed the shop/admin/includes/configure.php file to:

// define our webserver variables
// FS = Filesystem (physical)
// WS = Webserver (virtual)
define('HTTP_SERVER', 'http://pagan-magic.co.uk');
 define('HTTP_CATALOG_SERVER', 'https://pagan-magic.co.uk');
 define('HTTPS_CATALOG_SERVER', 'https://secure.avdns6.com/~********');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)
define('DIR_WS_ADMIN', '/shop/admin/');
 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);
define('DIR_WS_CATALOG', '/shop/');
 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

And have changed shop/includes/configure.php to:

 

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://pagan-magic.co.uk');
define('HTTPS_SERVER', 'https://secure.avdns6.com/~******');
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'www.pagan-magic.co.uk');
define('HTTPS_COOKIE_DOMAIN', 'pagan-magic.co.uk');
define('HTTP_COOKIE_PATH', '/shop/');
define('HTTPS_COOKIE_PATH', '/shop/');
define('DIR_WS_HTTP_CATALOG', '/shop/');
define('DIR_WS_HTTPS_CATALOG', '/shop/');
define('DIR_WS_IMAGES', '/shop/images/');
define('DIR_WS_ICONS', '/shop/icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

I have run www.pagan-magic.co.uk/shop/myenv.php but it returns no results.

 

When I reach the checkout section, the images dissapear and the padlock is not displayed.

I'm racking my brains, but I cannot figure out where I have gone wrong - please help, I'm still a newbie.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...