Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help Enabling - Setting up SSL


Platinum1926

Recommended Posts

Now I'm a little confused here.. I have an SSL with my provider..

In my oscommerce admin control panel.. It states "You are not protected by a secure SSL connection." is there some kind of help file to give me a walk through on how to enable my SSL. If not some help from the fine people here would be great..

 

 

:)

Link to comment
Share on other sites

That message is referring to your admin side - if you want to run it SSL then make your SSL server address your HTTP_SERVER in your admin/includes/configure.php

 

Matti

Link to comment
Share on other sites

Now I'm a little confused here.. I have an SSL with my provider..

In my oscommerce admin control panel.. It states "You are not protected by a secure SSL connection." is there some kind of help file to give me a walk through on how to enable my SSL. If not some help from the fine people here would be great..

:)

 

 

If you're having a difficulty at the admin panel of your shop, then try to change the code from your configuration file at the admin folder.

 

path

admin/includes/configure.php

 

Find this code:

define('ENABLE_SSL_CATALOG', 'false');

 

then replace to this

define('ENABLE_SSL_CATALOG', 'true');

 

and also into your configuration file at the storefront

path

 

/includes/configurate.php

 

find this code

define('ENABLE_SSL', false);

 

change to

define('ENABLE_SSL', true);

 

hope it helps

Link to comment
Share on other sites

If you're having a difficulty at the admin panel of your shop, then try to change the code from your configuration file at the admin folder.

 

path

admin/includes/configure.php

 

Find this code:

define('ENABLE_SSL_CATALOG', 'false');

 

then replace to this

define('ENABLE_SSL_CATALOG', 'true');

 

and also into your configuration file at the storefront

path

 

/includes/configurate.php

 

find this code

define('ENABLE_SSL', false);

 

change to

define('ENABLE_SSL', true);

 

hope it helps

 

I have tried this and it still syas that I am not connected !

Link to comment
Share on other sites

The ssl you have from your provider is most likely a shared ssl that you will have turn on with the control panel with your admin section of your service proider. Mine is IXWEBHOSTING, I have to log on to my account and trun on the shared ssl. The Shared ssl in only a sub level domain, ie. www.yourname."providersharedssl".com I looked into this, but did not know how to change the links on my website and move part of the secure site to the new folder. The admin section of your website does not have to be secure, but should be protected by a password. You should be able to do this in the control panel of your provider.

This is my understanding and I might be compleatly wrong but at the same time might point you in the right direction.

Link to comment
Share on other sites

The ssl you have from your provider is most likely a shared ssl that you will have turn on with the control panel with your admin section of your service proider. Mine is IXWEBHOSTING, I have to log on to my account and trun on the shared ssl. The Shared ssl in only a sub level domain, ie. www.yourname."providersharedssl".com I looked into this, but did not know how to change the links on my website and move part of the secure site to the new folder. The admin section of your website does not have to be secure, but should be protected by a password. You should be able to do this in the control panel of your provider.

This is my understanding and I might be compleatly wrong but at the same time might point you in the right direction.

Ok, thank you.

Link to comment
Share on other sites

I am having the same trouble implimenting my ssl certificate....and I have a dedicated ssl through godaddy. I can get the ssl to work but only if I hand code the "https" into the address bar. Oscommerce won't acknowledge the ssl, nor will it carry the ssl over through different pages after I log into the admin. Any help would be greatly appriciated.

 

 

-matt

---

CorradoMatt

http://www.westixonline.com - an oscommerce / creloaded site

Link to comment
Share on other sites

open your include/application_top.php

 

fine this

 

  $request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

replace with this

  $request_type = ($HTTP_SERVER_VARS['SERVER_PORT'] == '443') ? 'SSL' : 'NONSSL';

 

This will enable you to access https:// on godaddy network.....

Link to comment
Share on other sites

notice that only when you login, or checkout, or view your account, HTTPS:// will show, otherwise it will not show. However, you will notice when you click login, or continue though checkout, it will say you are redirecting to a none secure pages.. you need to modify any page say that to SSL...turn on....

Link to comment
Share on other sites

open your include/application_top.php

 

fine this

 

  $request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

replace with this

  $request_type = ($HTTP_SERVER_VARS['SERVER_PORT'] == '443') ? 'SSL' : 'NONSSL';

 

This will enable you to access https:// on godaddy network.....

 

That worked great, thank you !!! You saved me a lot of time and trouble. :thumbsup:

Link to comment
Share on other sites

Hi xnewbi3x, Your GoDaddy fix worked excellent for overall SSL site protection. I have one small problem. When I go to Administration I get the message in the lower left hand box "You are not protected by a secure SSL connection" with the little open lock. My browser show that I do have SSL protection. Is this something that I should be concerned with? I so, how would I correct this? Any help would be appreciated.

 

 

open your include/application_top.php

 

fine this

 

  $request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

replace with this

  $request_type = ($HTTP_SERVER_VARS['SERVER_PORT'] == '443') ? 'SSL' : 'NONSSL';

 

This will enable you to access https:// on godaddy network.....

Link to comment
Share on other sites

In catalog/admin/includes/configure.php,

 

find:

 

define('HTTP_SERVER', 'http://your_websites_url'); // eg, http://localhost - should not be empty for productive servers

 

replace with:

define('HTTP_SERVER', 'https://your_websites_secure_url'); // eg, http://localhost - should not be empty for productive servers

 

just add the "s" after HTTPS://

 

This fix by: lrparr

Link to comment
Share on other sites

  • 5 weeks later...
open your include/application_top.php

 

fine this

 

  $request_type = (getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL';

 

replace with this

  $request_type = ($HTTP_SERVER_VARS['SERVER_PORT'] == '443') ? 'SSL' : 'NONSSL';

 

This will enable you to access https:// on godaddy network.....

 

THIS SAVED MY DAY! Ive been working all day to figure this out. i called godaddy, they said it was because of my images... BS!!! thanks for this fix.

 

much appriciated!!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...