Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

stucked on the 1st step when installing oscommerce


eez

Recommended Posts

Hi! there:

 

I was trying to install the osCommerce and got stucked on the 1st step in the installation page. Any ideas about what is wrong there?

 

thanks

 

eez

 

1. I installed the apache 2.0.55 on the Windows XP SP2. then installed php 5.1.1. Then installed MySql 5.0.16 and create a database name oscommerce and create a new user osadmin and grant permission of the oscommerce database to this new user. After setting the php and apache, the apache is started ok.

 

2. then I copied the catalog directory to ApacheGroup\apache2\htdocs directory. restarted apache2.

 

3. go to explorer and typed http://localhost/catalog/install then I can see the installation page, then I clicked "new installation", I saw the second page. the two boxes about importing database are checked by default, I didn't touch them and directly clicked "continue".

Now the problem occurs, I was stucked on this page and cannot move to the next page, no matter how many times I clicked the "continue" button. There was no error message popped up by the way.

 

Anyone has an idea about what could be wrong with my settings or any log file I can have a look to find out what is the error?

 

thanks

 

eez

Link to comment
Share on other sites

Have you made the appropriate changes to the Apache httpd.conf file? Also you may need to adjust your MySQL to accept older version user/passwords. They have really good directions on doing that in their documentation.

Also, I have a really fast processor here, but it took a bit to import all the same. Watch your harddrive indicator. Could be it's working on doing everything.

Link to comment
Share on other sites

Hi! there:

 

I was trying to install the osCommerce and got stucked on the 1st step in the installation page. Any ideas about what is wrong there?

 

thanks

 

eez

 

Hi eez,

 

Look for these entries in your PHP.ini file;

register_globals = off

 

register_long_arrays = off

 

register_argc_argv = off

 

auto_globals_jit = on

 

 

 

Change them like so;

 

register_globals = off

 

register_long_arrays = on

 

register_argc_argv = on

 

auto_globals_jit = off

 

 

Give it try now.

 

Cybersilly. :thumbsup:

Link to comment
Share on other sites

Cool, looks like the problem in these 3 keys. After changed their values, I can continue the installation now.

 

thanks a lot!

 

eez

 

[register_globals = off

 

register_long_arrays = on

 

register_argc_argv = on

 

auto_globals_jit = off[/b]

Give it try now.

 

Cybersilly. :thumbsup:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...