Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Authorize.net decline message


ratbastid

Recommended Posts

Hi, folks!

 

I'm using authorize.net on an OSC site. I've used Auth.net a lot with other packages, but this is my first experience with it under OSC.

 

When a card number is correct and AVS passes, we do great. But when the card declines or AVS fails, I find myself back on the "Order Payment" page with no message or anything. When the card number is bogus, I do see an error message on that page. I believe in that case we don't even go to Authorize.net, but rather catch the LUNH imbalance locally. When the charge attempt declines inside Authorize.net, there's no notification about it at all, we just dump back to the Payment page.

 

These are custom-modified pages, and the modification was done by another developer, so I don't know much about what should or shouldn't be on these pages.

 

Any suggestions?

Edited by ratbastid
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...