Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Button images not showing


intradesigns

Recommended Posts

Okay, I did something, but no idea what. All normal images show up fine. However, ONLY the buttons in this directory don?t show up:

{site}/shop/includes/languages/english/images/buttons/

 

I deleted .htaccess.

I re-uploaded the images (binary) just in case.

Changed permissions to 777 in both buttons and admin/.../buttons

Checked two different browsers (IE & Firefox)

 

Here?s the only fine that?s changed (admin/includes/config.php). Anyone see anything I did wrong? The images were working yesterday, but now they?re not?

(I changed the site name with ?site? and the user name with ?user?)

 

define('HTTP_SERVER', 'http://site.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://site.com');

define('HTTPS_CATALOG_SERVER', 'https://site.com');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/home/user/public_html/shop/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/shop/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/user/public_html/shop/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/shop/'); // absolute path required

define('DIR_FS_CATALOG', '/home/user/public_html/shop/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

Thanks!

Link to comment
Share on other sites

The reason for this is almost always the .htaccess file in includes.

 

 

# $Id: .htaccess,v 1.4 2001/04/22 20:30:03 dwatkins Exp $
#
# This is used with Apache WebServers
# The following blocks direct HTTP requests in this directory recursively
#
# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration
#
# Example:
#
#<Directory "/usr/local/apache/htdocs">
#  AllowOverride Limit
#
# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)
#
# This does not affect PHP include/require functions
#
# Example: http://server/catalog/includes/application_top.php will not work

<Files *.php>
Order Deny,Allow
Deny from all
</Files>

 

The purpose of this file is to keep outsiders from accessing the .php files directly. If it's in place no one can just go to sumsite/catalog/includes/login.php for example, they'll get a 403 (Denied) error. But on some servers this file prevents the access of the button images which are within the includes folder.

 

You can rename the file (maybe xhtaccess) or you can move the languages directory out of includes (into catalog at the same level of includes)

 

If you choose to move it you'll need to edit catalog/includes/configure.php changing the location of the languages folder, like so:

 

define('DIR_WS_LANGUAGES', 'languages/');

 

Moving it has the advantage of keeping the core .php files protected in includes while not protecting the language folder with more or less harmless .php files in it.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Alan,

That is wild. I renamed, moved, then deleted the .htaccess file, but the images still wouldn't come back up. Now, after moving the languages folder, everything's working again.

Thanks very much for your help!

Ty

 

The reason for this is almost always the .htaccess file in includes.

# $Id: .htaccess,v 1.4 2001/04/22 20:30:03 dwatkins Exp $
#
# This is used with Apache WebServers
# The following blocks direct HTTP requests in this directory recursively
#
# For this to work, you must include the parameter 'Limit' to the AllowOverride configuration
#
# Example:
#
#<Directory "/usr/local/apache/htdocs">
#  AllowOverride Limit
#
# 'All' with also work. (This configuration is in your apache/conf/httpd.conf file)
#
# This does not affect PHP include/require functions
#
# Example: http://server/catalog/includes/application_top.php will not work

<Files *.php>
Order Deny,Allow
Deny from all
</Files>

 

The purpose of this file is to keep outsiders from accessing the .php files directly. If it's in place no one can just go to sumsite/catalog/includes/login.php for example, they'll get a 403 (Denied) error. But on some servers this file prevents the access of the button images which are within the includes folder.

 

You can rename the file (maybe xhtaccess) or you can move the languages directory out of includes (into catalog at the same level of includes)

 

If you choose to move it you'll need to edit catalog/includes/configure.php changing the location of the languages folder, like so:

 

define('DIR_WS_LANGUAGES', 'languages/');

 

Moving it has the advantage of keeping the core .php files protected in includes while not protecting the language folder with more or less harmless .php files in it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...