Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

authorize.net error


mjensen22

Recommended Posts

This is the error I get when I try to check out. I uploaded the authorize.net AIM, authnet_bug_fixes_20050118_msparr and then tried the SIM module because I don't know PHP or SQL - just learning.

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/content/k/a/r/karenalma/html/catalog/includes/functions/database.php:13) in /home/content/k/a/r/karenalma/html/catalog/includes/functions/database.php on line 13

 

help please. Everything is ready to go except for the payment module. I have the installation guide but it from the authorize.net website but the 56 pages is confusing for a novice.

 

THANK YOU!

Link to comment
Share on other sites

This is the error I get when I try to check out. I uploaded the authorize.net AIM, authnet_bug_fixes_20050118_msparr and then tried the SIM module because I don't know PHP or SQL - just learning.

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/content/k/a/r/karenalma/html/catalog/includes/functions/database.php:13) in /home/content/k/a/r/karenalma/html/catalog/includes/functions/database.php on line 13

 

help please. Everything is ready to go except for the payment module. I have the installation guide but it from the authorize.net website but the 56 pages is confusing for a novice.

 

THANK YOU!

 

Here is line 13

 

function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') {global $$link;

Link to comment
Share on other sites

First you should try disabling the module (which one are you actually using?) to see if you still get the error.

 

Which page are you trying to view when you get the error?

 

The function you quote is not the problem - the problem is that its being declared twice :)

 

Matti

Link to comment
Share on other sites

First you should try disabling the module (which one are you actually using?) to see if you still get the error.

 

Which page are you trying to view when you get the error?

 

The function you quote is not the problem - the problem is that its being declared twice :)

 

Matti

 

 

Thanks Mattie.

 

I get the error going from delivery information to payment information. I did remove and replace the authorize.net file each time.

 

Where should I look to get rid of the redundancy?

 

thanks again for any help you can give.

Link to comment
Share on other sites

Thanks Mattie.

 

I get the error going from delivery information to payment information. I did remove and replace the authorize.net file each time.

 

Where should I look to get rid of the redundancy?

 

thanks again for any help you can give.

 

 

Found the problem!!! I acidently uploaded a main page to the language folder. I found the answer here,

http://www.oscommerce.com/forums/index.php?sho...74entry612574

 

Thanks to Wendy James

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...